I am on broadband and have retained my old email address and use this at least once a month via dial-up to retain it, as it saves a lot of bother, if one has hundreds OS contacts to have another address.
However just recently I cannot send out emails, but only receive and surf the net.
To check this out I have a laptop(G3) which has the same dial up and this works perfectly well here on my home phone line as well as at a neighbour"s.
So the difference is that on the G4, in network, for TCP/IP the password is normally a 6 figure number, and for what ever reason on the G$ this has extended itself, no matter what I do to correct, to at least 12 digits,and hence at my provider it would be incorrect.
I have deleted and altered but on apply it reverts to at least 12 numbers. I have deleted and restarted but it still occurs.
I have just done 2 days ago an install and archive but to no avail.
I presume one cure would be to copy my HD entirely on to an external, and reformat etc, but seems a little over the top to do, which would cure it.
Any ideas anyone
Unknown information:
Type of broadband - DSL or Cable?
Specific ISP's name.
Service of 'old' e-Mail address.
G3 model name / number (iBook / PowerBook?)
System / MacOS X version of G3
G4 model name / number
System / MacOS X version of G4 (assumed 10.4, via title of original post)
e-Mail application(s) used on the G3
e-Mail application(s) used on the G4

Are the viewers expected to assume both the G3 and G4 are running MacOS X 10.4.0?
Assuming such ... in 'in network, for TCP/IP the password is normally a 6 figure number', do you really mean ... in 'System Preferences' 'Network's, ('Show:' popup set to 'Internal Modem'), 'PPP' panel the password ... ?

Assuming you are referring to the dial-up service ...
'However just recently I cannot send out emails, but only receive and surf the net.', if you are able to connect to the dial-up service and receive e-Mail's and surf the internet - than the 'System Preferences', Network's ('Show:' popup set to 'Internal Modem') 'PPP' panel (and other 'Internal Modem' related panels ['TCP/IP', 'Proxies', and 'Modem']) settings must be (most likely are) correct.
Shelsey, I wonder why you use a separate computer to access your old email account. You should be able to access your dial-up account over broadband. You will probably not be able to send email from that account--and I don't see why you would want to--but you should be able to receive. Just set up your dial-up account in Mail or whichever email client you are using. Furthermore, your old account may have a web-based client that alllows you to get your mail from any computer on the 'Net.

Another thing--I think that your are mistaking the padding of the ••••••• for adding extra characters to your password. Some systems allow passwords of varying length, but hides them with a fixed number of •'s. It is much more difficult to guess your password if the intruder has no hint how many characters it contains. The takeaway message is that your description of the password situation does not indicate anything to worry about.
Yes. Your sending mail problem is probably connected to the SMTP-server. What have you selected as your SMTP? Is it authenticated or a simple SMTP?