OS9 won't boot


Okay - I have searched EVERYWHERE for someone with a similar problem but can't find an answer...please help me if you can.

I had stupidly set the password security control panel on my firewire powerbook. This causes it not to boot in os9, or even a cd with os9. OSX WILL boot however, and I can install it and get access to my files.

To cut a long story short, I've been on a 'quest' to get myself booting in os9 again! I tried deleting the aaaaaAPWD file that contains the password etc in the root dir, and lots of other attempted solutions. I finally found a way to boot with the os9 CD again, by using single user mode to initialise the partition that contains the password. This was great, except once booted with os9 cd, the hard drive will NOT mount no matter what! Drive setup QUITS when I try to mount it. Holding down option at startup, it recognises the hard drive as an os9 volume, but when you select it, it just goes into flashing question mark over floppy drive thing.

I've ordered Disk Warrior, but won't get access to that for a while, so I really need to find another solution so I can startup in OS9 again! I have a feeling there's something wrong with the boot partition that doesn't affect osx, but causes os9 to have no idea what it's doing. The reason I'm posting this on a MacOSX forum is that I believe the way to fix the problem is to use the single user mode, the the pdisk command or something similar to fix the partition problem/s I'm having. I'll paste what pdisk outputs:

#: type name length base ( size )
1: Apple_partition_map Apple 41 @ 1
2: Apple_Driver_ATA*Maci_PwdDriver1.0 22 @ 42
3: Apple_Driver_ATA*Macintosh 64 @ 64
4: Apple_Driver_ATA*Macintosh 64 @ 128
5: Apple_Patches Patch Partition 512 @ 192
6: Apple_HFS MacOS 39069366 @ 704 ( 18.6G)
7: Apple_Free 10 @ 39070070

Please help if you can!
Hey, don't worry - I fixed it!! WOHOO!! I'll post what I did because not only did it fix my problem, but because it's a handy hack for security issues as well...

As I mentioned above, I tried to initialise the partition containing the password on it using pdisk in single user mode (holding down s on startup with mac os x cd as the startup disk). However, drive setup crashed on mounting the drive because it still saw this partition. So it gave me an idea - I needed to delete the partition, not just initialise it, despite what the original instructions I got off the macfixit.com report told me (I'll paste these below for you - there's also a step missing I discovered from these original instructions).

So I deleted it, and it worked! You now also have a way to disable the password security without worrying about what the password was in the first place. I rebooted, reinstalled the driver using drive setup and it mounted, blessed the system folder, restarted and booted...

Hope this is interesting and as exciting as it was for me...! I'm sorta glad I worked it out for myself too...

I succeeded at least – no reformatting!!

1. Insert a Mac OS X Public Beta CD into your CD/DVD ROM Drive.
2. Turn on the laptop and immediately hold down the 'Option' key to access the 'Startup Manager'.
3. Select the CD icon with the 'X' on it, then click the straight arrow.
4. Immediately hold down the 'S' key until the Darwin shell appears (Unix Command Line Interface)
5. At the 'localhost#' prompt, type 'pdisk' then hit Return.
6. At the next prompt, type 'L' (CASE SENSITIVE) then hit Return.
7. Look for a partition with 'PWD' in its' name (such as "AppleMacPWD"). It's usually the second partition. Note the number at the beginning of the line.
8. At the next prompt, type 'e' (CASE SENSITIVE) then hit Return.
9. Type '/dev/rdisk1s#' <-- replace the '#' symbol with the number you noted in Step 7, then hit Return.
10. At the next prompt, type 'i' (CASE SENSITIVE) then hit Return.
11. Follow the steps confirmation initialization and type either '0' or '1' for any block size allocations.
11a (missed step here – Ben) Type ‘w’ to write the changes.
12. Type 'q' Return; 'q' Return; until you are back at the 'localhost#' prompt.
13. Type 'reboot' and remove the Mac OS X Public Beta CD from your CD/DVD ROM Drive.
14. You should now be able to boot off a standard Mac OS CD, mount the drive, reinstall any needed software and then boot from the drive itself.

My instructions for deleting the partition:
1 Follow above steps to step number 8
9. Type /dev/rdisk1
10. Type d
11. Type the # that you noted in step step 7 (it was 2 for me)
12. Type w to write the changes
13. q and q again
14. Type reboot.

Startup off the os9 cd and do whatever you need to do to fix your drive for starting up again...

Powerbook G3 (Firewire)