OSX and netatalk


The following weird problem is driving me nuts:

I'm accessing a Linux box with the latest netatalk (Suse 7.1 and Debian 2.2, don't have exact versions right now.). I can see all my files, but some I can't open or copy, because "one or more required items could not be found (Error code: -43)".

I already tried the following things:

- chown -R'd the Linux directory. Same thing.

- Switched to identical user and group ids on both systems. Same thing.

- Made everything world readable. The world could read, but not I.

- Deleted the "Network Trash" and "TheVolumeSettingsFolder" on the Linux box as well as .AppleDouble directories.

- Created a brand new user both on OSX and the Linux box. No luck.

- Checked the Linux server with OS9.1. Works fine.

Is there anyone out there successfully writing to a Linux box that could shed some light on this?

Any help greatly appreciated,
But we both RTFM this time time, didn't we? ;-)
(Sorry, couldn't resist...)

Seriously, I tried 1.5pre6 on my SuSE 7.1 in the meantime, but I'm missing some setting, because it doesn't even let me log in anymore.

This is absolutely driving me nuts... It seems that not all files are created equal, as I can open some but not others. There must be some invisible bits - I've compared all visible permissions.

I also suspected capitalization but I can't see a pattern. E.g. I can open all files in a folder CVS/* but if move a bad file in there via the command line, it fails. Also, I have two folders "Mail" and "mail" and on opening either one, I get "Mail" (or the other way around, don't recall right now).

Well, it's weird , all my files on my netatalk partition has been copied there from other macs...

I log in as myself in my own home directory on the Linux box, gumse, and:
-rw-rw---- 1 suzi users 58259 Mar 27 14:08 Konsultprofil LG 2000eng #works, about the only file that works

-rw-rw---- 1 suzi users 51651 Apr 10 11:52 AK0103.SE # don't work

Another thing is that if you check "Privileges" i X on a file that does work it looks normal, but on the files that does not work it's all "grayed" out and it says "Owner System"
I have tried to alter the privileges on other files to mimic that of the working file, but no luck...
Found this:

From: Lorenzo Perone <lopez.on.the.lists@yellowspace.net>Subject: netatalk 1.5p6, OS X 10.0.1, OS 9...Content-Type: text/plain; charset="us-ascii"Hi,I succesfully got netatalk 1.5pre6 to work with my SuSE 6.3 box, thanks to MacConin for the /etc/pam.d/netatalk trick on SuSE, and to ./configure --with-pam --with-shadow --enable-suse --with-flock-locks --with-config-dir=/etc/atalk.To work, I mean it _looks like_ the best version _working fine_ with OS 9 until now. -[In our case, _fine_ means: fair speed in transfers of thousands of small files and dirs; opening/saving big image files on the server; opening/saving text files; succesful use of GoLive's site features (a hard test, I know...;); use of FileMaker files; with a lower priority, but still important: succesful launching of applications from the server; succesful mounting and use of images (.smis and .imgs and .dimgs). The first are the tests that I usually perform after a new build. Apps and Images follow if the first pass. When I want to be really evil, I also try to open MS Office files on the server ;)]-1.5p6 passed all tests with OS 9 (still testing for reliability and with more clients, though)... but OSX is still cut out of the sourceforge tree... or did anyone get it to work any 1.5pX reliably?After compiling different versions on different platforms, it came out, in my cases, that:eek:nly netatalk 1.4b2+asun2.1.4pre37_test (with -DUSE-FLOCK-LOCKS) gives the impression to work with OSX (few errors, succesful transfers...), but then causes sooner or later Darwin to panic. On the other hand, my OS9 clients keep freezing and caughing with the asun builds....all sourceforge netatalk versions I tried (and some newer asun builds) rarely caused Darwin to panic, login was possible (some _only_ thanks to the trick of using -loginmesg "something" in afpd.conf), but then they caused OSX to display a lot of Error -43's, sometimes -50, and one time 8021. netatalk 1.5pre6 behaves the same with OSX (-43s), except that with --enable-lastdid did files where transferred partially (even if the error message was displayed in the osx finder).and 1.5pre6 still causes theafpd[xxx]: setdirowner: chown -1/0.AppleDouble/.Parent: Operation not permittedmessages noticed recently...(when used with _OS 9_ - I couldn't get it to happen with an OSX client)One strange thing of these messages: they seem to assume that afpd is running as root, as noticed by M.K. - I've seen this happening only with netatalk1.5pre3 on LinuxPPC 2000 Q4: All afpd processes were running as root, but the users still got their correct access rights to the share folders (note: no admingroup, plain users).I also noticed that that was the only combination of Linux+NetAtalk which transfered very fast also directories with thousands of files and subdirs: > 5MB/sec on a PMac G3 DT/266, while others don't get over 1-2-3 MB/s.Where can this (root/nonroot) be set? Is it set by --enable-redhat (which I used for LPPC)?...hope this post helps...please keep it going, you're doing a good work on the sourceforge project, I believe - but pleeeease let us netatalkers enjoy OSX soon ... ;):-|LP
That's interesting. I have to admit, though, after reading this and some other sources, I wouldn't have a whole lot of confidence into any setup that somehow might be working at this time.

By some stroke of luck I'm currently able to read and write some 50 source files that I need, and I think I'll leave it at that. As your source puts it, it's probably best to wait for a new version of netatalk...

Im not sure if it was 10.1 or 10.1.2, but now I can access my linux box again.
I have done nothing to linux or atalkd so it must have been a fix on the OS X side.
works great.