OSX Installer sees disk, won't choose one

astrodawg

Registered
Hello,

Problems installing OSX on my G3.

It is a G3 233 Rev A. It has a new motherboard and rom chip so it now thinks that it is a G3 266 Rev B. 288 mb ram. The drive is not the original drive, but is a Western Digital 13 gig drive. Public beta worked.

I backed up everything and booted with the OS9.1 install disk to reformat the hard drive.

When I try to install OS X, I get to the choose disk screen and it shows my disk, but it is greyed out and I can not select the disk. I first started with two partitions, but went back to a single partition. Same thing. I have tried disconnecting all usb and scsi devices... same problem. So, I installed 9.1 and tried to install OSX again. Same problem.

I simply do not know what else to do. Any suggestions?
 

doppelbock

Registered
What size partitions did you make?

The documentation states that on the beige G3's, X must be ENTIRELY within the FIRST 8GB of the drive.
 

astrodawg

Registered
Tried UFS, tried starting with HFS. Either way, I still can not choose a drive even though I can see it. The installer knows its there.

I am back to one partition, 12.1 gigs.
 

astrodawg

Registered
Out of curiosity, I attached my powerbook to my desktop computer... the powerbook in scsi mode. Booted the desktop from the OSX cd and was able to install on the powerbooks drive. However, the desktops drive was still visible but unavailable. OSX just does not like my drive.
 

doppelbock

Registered
I'll say again....

The documentation cleary states that on a beige G3 that X must be COMPLETELY WITHIN THE FIRST 8GB of the drive.

So, if you have one 12gb partition, it ain't gonna work....

Try partitioning into 8gb and 4gb partitions....install 9.1 on the 4gb....then install X on the 8gb.

 

astrodawg

Registered
I took that to mean at least the first 8gigs. I'll give it a shot. Thanks.
 
Top