Osx Not Reading Cdrom


I am taking a class that requires a cdrom for some lectures, and my mac is NOT reading the disc! I have called all the tech supports for the software and the class, but they themselves are not Mac users, and probably don't understand the problem. My computer is an ibook running OS X 10.3.9, and when i put the cdrom in, it reads it as if it were a blank cd. The folder for it appears to be completely empty. I have tried it on other computers, and know that the disc is ok. The software says it is for 9.2.2 or 10.3 or higher, and i tried it in classic mode too with no luck, though i am not used to classic mode and may have done it wrong.
any thoughts? i am really unnerved because we have an exam on Monday!
thank you,
Without knowing anything at all about your CD-ROM, we can only take a shot in the dark at best. If you are using a commerically produced disk, then I have not a clue why you cannot read it. If the disk was burned on a Wintel computer, then there may be an explanation. Often Windows people will forget to "finalize" the CDs that they burn. The CD may appear to be OK on other PCs and are only waiting for additional data. However, these CDs simply will not work in other devices because they are not complete.