Osx Tiger And Epson 1280


after many speedy but useless tips on how to get my once functional Epson 1280 to operate with Epson 10.3 drivers, the email reply from the Epson tech support told me bluntly, "You JUST HAVE TO WAIT for OSX 10.4 drivers..." . Whoopee, since the 1280 is still a featured item on the Apple page... I am using the gimp-print drivers to work now and then so I can continue with my small transfer business, but for neither the 1280 nor the Epson CX4600 will Printer Utility work. It seems Gimp-print (supplied by Apple as the OSX 10.4 driver) driver include Printer Utility recognition/interface. Can anyone help me? I am HOURS into the subject, and since Epson said "tough luck", I feel helpless-er...
I have influence over 200 artists who have epson printers, I think I will advise to purchase HP instead.

What a joke.
And MAC.com offers your comment as a possible solution to my problem. Should be return to PCs and Windows? Another MAC problem is NO WEATHER STATIONS have direct Mac link software. Are our pockets so lean that no companies seek our $$ ?
Hi, I also have an Epson 1280 printer, using it with a new iMac g5. It's printing, but the color rendition is so horrible that it's making me consider returning the Epson which I purchased with the iMac. (Printer is a factory reconditioned one from Epson direct.) Never had trouble getting it to print, but never liked the results.. way too red. Yes, I have Photoshop CS and am using the proper color profile supplied with the printer.
I am trying to get into a class on color rendition- you can print a page and then learn how to make specific settings for THAT printer and THAT same medium. However, my problems with the 1280 and OSX104.2 is that there is a LANGUAGE barrier and the colors print separately on separate pages and there is no access to Printer Setup Utility. Do you have access to Printer Utility for your EPSON 1280, and if so, what OS are you using? 10.3 worked fine....HHEELLPP!!
I had a similar go-round over my Epson 2200 (and was startled to see the GIMP default drivers). However, despite Epson's advice to "wait for new drivers," when I just re-installed the old Pre-Tiger Epson drivers, they worked perfectly. Possibly you might have similar good fortune...