OSX Tiger won't connect to XP

mahakala

Registered
Ok, I have read threads, blogs and articles all day to solve this problem:

I just purchased a G5 with Tiger. Need to connect to my office windows network (ethernet with hub and cable modem attached to hub for internet).
I turned on windows sharing, setup the users. On my XP machine file sharing is enabled.
The G5 can connect to the Internet through the hub, no problems. It can also connect to our Dell Laserprinter with built in print server via IP mapping. Got all that. Then I can ping the G5 from the XP box and vice versa.
I just can NOT connect either way.
Under System Preferences, Windows Sharing displays the following path for the XP box to connect:
\\c-24-126-94-70.hsd1.ca.comcast.net\jens (jens is my shared).
That does not work at all. I also tried just the IP#, or just the Mac name.

The windows box does not show under servers, I even named the workgroup the same.
I've been trying all day now and don't know what to do. Can anyone please give me a hand with this? Lots of people have done this successfully.

Thanks very much for your time!
 

Carlo

All your base are belong
Your sharing your office kit over public internet with no VPN or protection.. ? and your advertising this fact.

If you have not VPN then you need to get one. If I mis-understood then sorry.

If your trying to connect to a windows server you need to ensure that you have disabled the windows encrypted login (this effects 2003 server, you will need to talk to your admin about it).
 

mahakala

Registered
Carlo said:
Your sharing your office kit over public internet with no VPN or protection.. ? and your advertising this fact.

If you have not VPN then you need to get one. If I mis-understood then sorry.

If your trying to connect to a windows server you need to ensure that you have disabled the windows encrypted login (this effects 2003 server, you will need to talk to your admin about it).
The IP# I listed is not the real one, I would not share it, just to give an idea of what I'm getting.

I am not running a VPN as all PCs and the G5 are on a LAN via Ethernet.
Our windows server is an old NT 4.0 machine.

I found out the problem now:

The IP#'s are assigned by the Comcast cable router/modem (internet access) attached to the Lan. The IP#'s start with 24, so I am in the wrong range.
When I disconnect the cable modem and reboot all machines, our NT server assigns IP#'s starting with 169 (local ones). Using those #'s I can successfully connect the XP and G5 boxes and share files.
Dilemma is, as soon as I then re-connect the cable router to the Lan hub, it re-assigns IP's (back to 24.xxx.xxx.xxx) which kills the shared connections between G5 and XP boxes.
If I configure the IP's as manual, they won't get changed by the router, but then I don't get Internet access.

So what is the solution here?

Thanks again .
 

elander

Registered
Here's what I would try: allow the router to set the IP #s. Then change the settings on each computer to "DHCP with manual address", with the same numbers that they got from the router. Then the numbers won't change over time, and you should be able to reach the internet. Then restart the computers, and try to connect them to each other again.
 
Top