OSX Trash Bin won't trash????

mmx380

Registered
I tried to delete something last night, and something left in the trash bin and says " The operation cannot be completed because you do not have sufficient privileges for" the file name" .

I tried to hold down "Alt" and "empty trash" it still not working. Now the trash stay in the bin and i can't do anyhting about it. What can i do to get rid of it? Help please.

I myself is admin of this machine.


G4 466Mhz
384 Ram
OSX 10.01

 

maxebb

Registered
I've had the same problem throwing away printer drivers. The thing was, the item I was trying to throw away was being used by OS 9 in some way. I have no idea how the new garbage disposal works under OS X and 9 but it did amaze me to see they were keeping track like that.

Anyway, If X said I couldn't throw away, then I reboot with 9 and throw it away there.

btw, I'm getting really sick of restarting between the two.

max.
 

macboy73

Member
First, it is the Option key on the Mac. I think you would like to be familiar with that terminology, as this key is rarely referred to as Alt.

Second, I'm not an ogre and I will help you! What it is telling you is absolutely true. Your user account does not have permission to delete this file. Something that Mac OS 9 veterans will note is that Mac OS X is a multiuser system. You need to log in to use it (if you have automatic login enabled [like the default], you may not even be aware of this). What this means, is that all users have specific privileges regarding what they can read and delete, etc. This is similar to File Sharing privileges in Mac OS 9, but you have these same privileges when using the machine first-hand as well. In a UNIX system, like Mac OS X, this can restrict what a user may remove. This is your case. Also in UNIX, there is a super user, that has total access to the entire file system, called root. This does not mean the Administrator privileges that you are given by default in OS X. Root is the ultimate superuser, it can do ANYTHING to the file system. For this reason, Apple has disabled this account by default. If you are logged in as root, you may very well render the operating system unusable, and will have to reinstall. However, if you know what you are doing, you should enable the root account; it can be quite handy at times (such as your situation). Apple has left a very simple (although discreet) way to enable root:

Open the NetInfo Manager application (located in /Applications/Utilities). Under the "Domain" menu, select Security->Authenticate. Type your user name and password in the prompt that appears. Next, under Domain->Security, select "Enable Root User". The system will probably ask you for a password to use for the root user. It is probably best to use the same password you set up with your default account. After you have done this, quit NetInfo Manager. Log out (Apple menu). When the login screen is displayed, type in "root" as the user name, and the password that you just setup with NetInfo Manager. After you have logged in with this user name, you have privileges to do anything. Including delete anything.

The easiest way to prevent problems with privileges. On the desktop, select your hard disk(s), and pick Show Info from the File menu. Select Privileges from the popup menu in that info window. In the privileges section, check the box that appears at the bottom of the info window that says "Ignore Privileges". What this means, is that ANY user has the privileges to modify the entire filesystem. You would most likely only want to do this if you are the only person using your computer. Also, if you do this, you must remember to never do one thing: NEVER EVER touch the System folder in X unless you know what you're doing. That is essentially the only thing that you need to remember when selecting this option. After you have done this, then log out again. When you get the login screen, type in your username and password that you created when you ran the setup assistant after installing OS X. At this point, you should be able to empty the trash.

Please let me know if this helps. I know it's quite long and may be unclear in places. if you need clarification, please tell me.

Good luck.
 

maxebb

Registered
hey, are you calling me an ogre? :)

actually, now that I think about it, simple unlocking the files manually allowed me to throw them away.

 

VGZ

Registered
Holding option when choosing to empty the trash would delete locked files under 9. Apparently this has not been implemented under X. It would be a good idea to send feedback to Apple requesting that they implemment this feature. But first check to see if this has been implemented in 4L13 (I'm away from my comp and can't check that now).
 

spike666

Registered
i had the same problem with a file.

i even tried going in under Terminal.app and su-ing to root and trying to rm it. couldnt get rid of the file. yes its locked, but i cant unlock it either.

i couldnt even unlock it after logging into the machine as root and using the finder.app to try and unlock it with root privs.

i finally just moved the file into a dead file directory.

any other suggestions?
 

mmx380

Registered
When i try to move the file from the trash, it just copy a new set of locked file. It just getting more and more. Now every time i empty the trash, i have to click about 50 times "continue" to trash the other things. It is not acceptable. I think i am going to reinstall OSX and be careful of that folder.
 

acalado

Registered
Try a shareware app called DropObliter8. When you encounter a problem file, just drag it over the DropObliter8 application icon and it will remove it 75% of the time the Trash won't.

DropObliter8 can be found at www.versiontracker.com

Andy
 

Eid

Registered
OK 1st up doing this COULD be dangerous.

The messages are there to tell you something like 'hey mate, that there file aint your, it's Bubba's' (Or more likely root's, say for binning an app you don't want, or an app the the developer has been a bit careless with permissions on, or what ever!)

OK with that out of the way: Load up terminal, if you have root enabled you can su (switch user) to root
> su
> <i>password</i>

then go to your trash directory (home/.Trash, I.E. /Users/ben/.Trash)
>cd /Users/ben/.Trash

you can now delete all your files using the following command
> rm -rf *

*** WARNING ***
THIS WILL RECURSIVELY DELETE ALL FILES IT FINDS

In other words once you type this everything from .Trash upwards will be gone, which is what you want.

I like doing things this way, since it is less likely I will delete the wrong stuff. (I also usually have a look before I trash using the ls -al command)

You can however do it all in a one-er
>sudo rm -rf /Users/ben/.Trash/*

you will then be asked for the password.

(BTW replace 'ben' for your user name, but I'm sure you knew that already!

Hope this all helps and doesn't trash your ENTIRE HD!

Eid
 

Houserican

Registered
If you create a file in Mac Os 9.1 you somtimes cannot delete them in Os X no matter what. If you create somthing you should put it into your home directory. You can try loggin in as root and deleteing the files that why but like i said if you created tem in 9.1 u wont be able to.
 

rharder

Do not read this sign.
To complete the thread, I'll add that to unlock a file from the command line you use the chflags command. You can unlock a file or a folder, recursively even, with a command like this (recursive technique):
Code:
% chflags -R nouchg *
If you find that you don't have permissions to do this (different from the lock issue) you can kill two birds with one stone:
Code:
% sudo chflags -R nouchg *
Password: <em>myInvinciblePassword</em>
I think there's another thread on this board that discusses this in more detail.

-Rob
 
Top