Partial Printing With Epson 1280


Running 10.3.9
640 mb ram
Photoshop CS
Epson Stylus Photo 1280 with newest 10.3.... driver from their website. USB through a hub.
I often get partial prints, especially with larger size files, but even sometimes with small ones. Photoshop has 100% of memory allocated in the preferences. I am wasting a lot of paper, and after a couple days of going back and forth with Epson, they now say to call Adobe.
I printed one complete 9x13 43mb print yesterday. Went back and changed some shadow detail, and with the same exact settings it only printed half a page, and then ejected the print half done. This 11x14 paper ain't cheap. The other day I was working on a couple 5x7 photos that were only about 10mb files. It kept printing about a third of the photo and then stopping. I turned off Photoshop, and then back on; it then did a complete print. Tried the second photo and got half of it. Turned it off and back on again and got a complete print. That's when I checked for a new Epson driver. I just installed this version of Photoshop recently, so I don't really believe it would be Adobe's fault, but I'm lost now. Everytime I print I don't know if I'll get a complete print or not.
Thanks for any input you can provide to solve my problem.
delaneyt hi. I don't have personal experience with this printer. But let's see if this works. Have you tried saving your file as a PDF and then printing it? I think your problem sounds like a memory issue. Creating it as a pdf just might solve this. Let me know.