Permission Problem - File Attachment


I am having a problem in OS X with permissions.  Or so Apple is telling me.  I was trying to attach an excel spread sheet in MAIL, and when I went to the directory where the file was, it did not appear in the list.  (Almost like in windows if you don't have all file types selected)  I could see iTunes in the Documents folder, but not my excel file of the folder it was in.  When I browsed the documents folder, I could see everything.  

I called Apple expecting them to say it was a known issue in Mail 1.0 and that it would be fixed in OS X 10.1 release.  The rep said it was working on his system.  I was having trouble with Mail quitting as well.  I expected him to say it was a known issue as well.  It needed to be force quit if I hit get mail - but not if I didn't hit get mail.  (ODD)  So after screwing around trying to get the permissions fixed, he had me do a reinstall with the OS X disk.

When I setup the system, I put in a brand new 20GB IBM TravelStar drive.  New install of OS 9.1 right from the disk (no patches - except for software update).  Then Installed OS X from the purchased CD's.  SO it's not like there was any junk that caused a bad install.  I also used the Easy install - so it's not like I turned anything off.  The system was setup with 1 user only - Administrator.  After I ran the OS X disk again, it put me back to the OS X original install.  I did the software updates again.  Mail works properly now.  It quits even when you check mail, but I can't see the file still.  I tried adding another Admin, but the permissions were the same, and I still couldn't see the file.  I went to the hard drive (get info) set all levels to read & write - then did the copy down function.  I even tried to ignore the permissions.  Still can't see the file to attach it.

The only other info I could provide is that I booted to OS 9 and ran Office 2000 to create the file.  The tech at Apple said it shouldn't matter.  My drive is not partitioned in any way other than what the Easy Installer might have done.

Does anyone know of any terminal commands that might fix the permissions, or is this file causing some sort of problem?



Two good apps for checking OS X files and permissions are xFiles and Super Get Info. SGI is from Bare Bones Software, but I don't know who makes the other.

In xFiles, trying deleting whatever creator info is there, or just change both permissions levels in SGI. I don't know why you are having this problem, but maybe this workaround will help.


Unofficial Mac Genius
Probably the easiest way to set permissions for your file so you can see it is via the Terminal, even though you might not think it's that intuitive. Just follow these steps:

Before going through these steps, you might want to try this simple action to see if the file will attach.. find it in the Finder, and drag and drop it on your mail message. If it worked, you should see a Finder icon of the file appear in the mail message, where you dropped it. Then you can send your mail with the attachment! If it still gives you permissions errors or that does not work, follow the following steps (you may want to anyway so that it won't give you trouble later).

1. Open the Terminal application.

2. Type 'su' and then hit return. Type in the root password and hit return. NOTE: This will give you access to do anything you want via UNIX, and no confirmations of actions will be given. If you think you do not want to do this, just quit the terminal. However, if you follow exactly what I say, it is unlikely that you can mess up your computer in any way.

3. Type 'cd ', yes with the space. Don't press return yet.

4. Drag the enclosing folder of the desired file on to the terminal window. The full path to that file should be automatically entered. This may cause the Terminal to quit: if so, restart your computer and start at step 1 again.

5. Hit return. You should now be in the directory with the desired file. To check, type 'ls' and hit return. Your file should appear in the listing.

6. Type 'chmod 777 filenamehere', and then press return. This will give all users complete access to the file. You may now quit the terminal and you should be able to access the file via Mail.


The system would not let the Admin log in. I created another admin. Then deleted my original user. (Oops - forgot about mail & pref's) I went back and re-created the account. Everything seems fine now. When I created the new admin account, I was the account that wouldn't let me in. Anytime I do updates, the password I was using was the same. Wierd. It seems ok now though.

New Problem:

How do I get my mail back? My account restored all the files on the HD when I setup the account again. My other 3 mail accounts did not restore the mail though. Does the account description need to be exactly the same? (since the mail all restored) If I don't remember the exact description, is there a directory I can look in to get the info?



The reason your email account was restored is because it is an IMAP account. Everything is on the server in the first place, so there is no need to restore it. Your other accounts were probably POP3 accounts, in which case you probably didn't leave your messages on the server. If that's true, then they are just lost. Sorry.


I was trying to get a mail I needed out of my deleted users. I found the mail folder and drug it into the mail app folders. I could see the mail RE:, but when I clicked the mail, the content was gone - sort of like the pointer was removed. I think I am going to do a clean install when my OS X.1 gets here. I am seeing more people with permission problems - so I don't feel as bad. The thing that was disturbuing was I was going to partition the drive to keep 9.2.1, OS X.1, and the data/apps on different sections. Is this advisable, and is the performance better?



Official Mac User
Your old eMail Prefs may be stored in the folder ~uruserdir/library/mail/..
If u cant find this folder, u could try to boot into Os9 again, and then search it there using Os9 Sherlock.

The Mail App often hangs up when one disconnects from the internet while the Mail App is still running.