Permissions Problems

sari

Registered
Hi,

We have a G5 running OSX Server 10.3.9. The clients are running OSX 10.3.9. some of which are running using the OS software they came with and others are using the client license as we upgraded from 9.

I thought we had solved our permission problems but out of the blue they have reared their ugly heads again. On ther server all the users have a sharepoint to a public folder. Each user has the settings on the server as: Owner user name Read and Write, Group staff Read and Write, Everyone Read and Write.

The 'shared folder' has Owner admin Read and Write, Group staff Read and Write, Everyone Read and Write. Its protocal is to inherit permission from the parent.

However, when I create a new folder in the shared folder from a client machine, the details in the info window tell me that the Group staff is Read Only. We have to change this manually everytime we create a new file/folder.

How do I get these folders and files to be created so that the group staff can see them without it being done manually? We had actually managed it but it suddenly seems to have gone out the window.

Thanks
 

WHBA

Registered
I don't have anything to add, but I would like to see a response, as I face the same frustrations. As the "IT" guy in our firm, I would like to have full RW access everywhere, but any folders created by my coworkers, no matter where they get created, are read only to me. I can always go in and change things, but it is a headache to do this to every file or folder, when in reality they should all be inheriting the properly configured permissions in the folder hierachies I try to enforce.

So, just a bump to this post, and I can say that I'm running OS Server 10.4.7 and this is still an issue.
 

BitBotherer

Registered
Hi
I had the same problem a while back, solved it by command line setting all permissions to 775 which gives everyone in the group read,write and execute permission. Every now and again we have the odd prob. I think it is caused by someone writing an old file to the server.
Vin.
 

MacDoug

Registered
It's a bit scorched-earth, but have you tried disabling and recreating the shared volume? In other words, uncheck the "Share" box in Workgroup Manager, save, then recheck it and set all the Access properties as desired? This may jiggle the handle and reset the permissions issues.

If upgrading to 10.4 server is an option, I highly recommend it. The inclusion of ACL's relieved a whole lot of the exact same headaches for me in this area! Clearly 10.3's inherited permissions implementation was less than perfect...
 
Top