PHP4 on Mac OS X 10.0 ???

Andrew Hill

Registered
Well, the install instructions in the Manual are pretty close.
To point you in the right direction:
- what is your configure line?
- how do you know it's not working (error messages, etc)

Best regards,
Andrew Hill
 

snowgurl

Registered
Originally posted by vic
i installed php the stepwiseway, but it still gave me :

Parse error: parse error in /Library/WebServer/Documents/php.php on line 5

why?
I think I have a solution for you. I was having the same problems over and over. I reinstalled twice and no luck. I made sure to use BBEdit and save as UNIX but they still didn't work. But the phpinfo file was working fine. Then I noticed that the error was always on the line between the <? ?> no matter what I put in there. When I left it empty the page was fine. Anything that I put in there threw an error. Then I noticed that the BBEdit tag colors weren't showing up (you know how certain tags are different colors?) I went through the preferences and saw that the "smart quotes" and "smart edit" were on. I turned them off, the pages showed up with the tag colors, and they showed up in the browser with no errors! It was such a little thing but made all the difference! Check it out on your BBEdit, if you're using it. If you're not using it, get it!

Hope it works!
 

vic

RRRrrrRRRrrrRRrrr
don't wprru about me now, i got it working.... and then fucked it up with the new 10.1 update!
 

TommyWillB

Registered
I finally go around to installing the developer tools, and that did it... PHP now works with 10.1.

Next up... getting a database going. from what I've gathered so far, MySQL is the preferred solution. Right?
 
Top