Pine not working right after 10.1


ok, this is the only thing 10.1 broke that i have not been able to recover from. it started when after installing 10.1 i launched pine and got an error that /var/mail needed to be 1755, so i chmod'ed. on next launch i immediately received some type of database error that i didn't catch. turned out 10.1 overwrote postfix with sendmail. after removing the new sendmail, postfix/pine would recieve mail but not send. after the 10.1 dev tools were downloadable i recompiled and reinstalled postfix. now postfix is working fine (it receives and sends, generating NO ERRORS in mail.log).

but pine itself is not so happy with 10.1, after reinstalling postfix, pine will send an email, but right after sending pine aborts and dumps me to the command prompt. the mail does get put in the outgoing que and sent, but doesn't get to the point of writing to 'sent - mail', i repeat, mail.log is error free, i see nothing like "pine.log" to look in, i tried downloading/compiling/installing pine4.40 that was released last month, but it gives the same problem. here's the exact error it gives:

Problem detected: "Received abort signal".
Pine Exiting.

any ideas on this one guys? i'm really would like to resolve this one but am stumped at this point. (yes i checked the file permissions on 'sent-mail', no they haven't changed from before 10.1)

i just tried deleting 'sent-mail' and letting pine recreate it, after it recreated, it just aborted again.


Notorious Olive Counter
I've got the same problems. I have not got the new devtools yet, Apple's server being busted, so I'm using the old 10.0.x cc and so forth for compilation...

I don't even see any evidence the mail is getting sent - sending mail to myself, nothing gets through.


Notorious Olive Counter
10.1 puts in a .forward for root, consisting of the text


Postfix doesn't like this any - I get a bunch of files in /var/spool/mqueue, like this:

$ ls -al /var/spool/mqueue/
total 24
drwxr-x--- 8 root wheel 228 May 22 03:16 .
drwxr-xr-x 9 root wheel 262 Oct 9 15:06 ..
-rw------- 1 root wheel 57 May 20 03:15 dff4K9FKn10156
-rw------- 1 root wheel 57 May 21 03:15 dff4L9FZe24486
-rw------- 1 root wheel 57 May 22 03:16 dff4M9Gbs27168
-rw------- 1 root wheel 789 May 20 03:15 qff4K9FKn10156
-rw------- 1 root wheel 829 May 21 03:15 qff4L9FZe24486
-rw------- 1 root wheel 789 May 22 03:16 qff4M9Gbs27168

$ sudo cat /var/spool/mqueue/dff4K9FKn10156
/var/root/.forward: line 1: >/dev/null... Unbalanced '>'


Notorious Olive Counter
Any time pine executes an external program, it seems, it dies.

I get the same result if I try to read a PGP signed or encrypted message - gpg starts up, checks the signature, and then on gpg's exit, pine dies with the same message.


First, you can change the /var/root/.forward to be your username (replace the /dev/null with your name, or a full addr), so you get any mails that were sent to root. I get 1 mail per day from the daily update cron job... personally I'd just as soon see these mails, never know what useful debug I might find, or errors I might catch.

It won't directly help you, but I can pass along that both elm and mutt still work just fine under 10.1.

I just tried an fink install of pine, but it appears the version is out of date and no longer exists...

Make sure you have a sendmail process running (ps -aux |grep sendmail) just in case it still having trouble after the update.

Sorry can't help more,