Playing VCDs in X

jove

Member
I just sent this to Apple feedback. Has anybody experienced something similar?

Hello,

After exporting a CDROM medium quality movie from iMovie 2, I import it into Roxio Toast Titanium (booted back into 9.2.1) to create a VCD. The VCD is burnt without error. The resulting VCD has a VIDEO01.MOV file on the root of the CD. Under MacOS 9 I can double click the movie file and all runs correctly. Under MacOS X, with the same file, the QuickTime player shows a white screen (movie should start out black) and QT player becomes frozen on play (with spinning beach ball). QT player can be force quit. I have not tried the VCD under Windows.
 

kenny

Registered
Are you sure that you burned it as VCD and not a data CD??? VCDs do not put media in the root of the volume. With VCD1.x, it's in (IIRC) /MPEGAV. And it is usually named with a .DAT extension.

That said, I've burned a number of VCDs that I couldn't even get to play under MacOS9, much less X, but I can play them in my DVD player (Pioneer 434) with no trouble. Also, using a VCD ripper, I can extract the MPeg stream and play that as a file under X.
 

Abakadoosh

Smiling 'till death
kenny, you obviously havnt burnt a vcd with toast. it creates this file for easy reference (its only a couple k). its just a link to the main file so that a mac user can pop in the cd, open the file, and it will play the movie. jove, the file that it links to is the .dat file in the mpg something or other directory. just open that up in quicktime and all should be fine (havnt tried it under x, but thats what i did when i created VCD's on the PC downstairs on OS 9). you could always find a VCD player (i know there was one for OS 9, but dont know about X) and do it that way, but this is easier and doesnt require a third-party app. have fun.
 

jove

Member
The player kept giving me errors when opening the .DAT files; either missing component or i/o error.
 

kenny

Registered
The fact is, Abakadoosh, I've burned quite a few VCD's with Toast, but I generally use a standalone DVD player for playback. To be honest, I guess I'd never noticed the .mov's in the root of the disk. I've got a Terapin recorder that (of course) doesn't put the files in the root, and commercially pressed VCD's don't have the files in the root.

As a quick test, I burned a VCD on my iBook just now with Toast (on MacOSX), and sure enough the files are there in the root. What's interesting is that it will not play on X (as Jove has noted), but it will play on MacOS9 (a surprise to me) on the same machine, and it will play on Windows (XP) but of course you have to open the .DAT files directly.

There's likely something up with the drivers for CDROM under X; VCD's are not generic ISO9660 discs, and need to be handled a bit differently. Clearly, this is not happening In any case, I'm seeing the same thing, and will go ahead and post this with Apple too..
 

praj

Registered
I have been buring VCDs in classic with Toast for quite some time. They all are working fine on my DVD player. In Mac OS X, the root folder shows the .MOV files and double-clicking opens QT player, which freezes..

- Praj
 

jove

Member
Hello,

I have had mixed results from my VCD

1) iBook MacOSX
Crashes QuickTime

2) Friends DVD Player
No Disk Error

3) Windows Machine 1
VCD sometimes mountable, Media Player no times playable

4) Windows machine 2
VCD mountable, Media Player not playable

5) Windows machine 3
VCD mountable, Media Player playhead movable but play fails

6) Windows Machine 4 and 5
VCD mountable, Media Player playable

Haven't tried QT on Windows. The CDs is 16x. Are VCDs really this unpredictable?
 

kenny

Registered
Originally posted by jove
The CDs is 16x. Are VCDs really this unpredictable?
Actually, no, but there is one factor that springs to mind at the mention of 16x CD's here.

About a week or so ago, I burned an audio CD to play in the car. I used iTunes, with all the defaults on my Que! FW burner. As it turns out, iTunes burned @ 16x, even though the media is labeled for up to 8x. My not-so-scientific tests indicated long ago that this media (Memorex bulk, blue-green dye) was sort of dodgy at anything over 6x, but I just bumped my head and didn't think to check what iTunes was set to do. Now, the disc played fine in both of the drives in my G4 tower, and played fine (all spot-checking, of course, so there could have been problems I didn't see. Once again, scientific... ;) ) in my stand-alone DVD player (Pioneer 434). BUT - when I got to the car, the player wouln't read more than the first 20 seconds of the disk and then stop.

Since the layout of the video stream on a VCD vaugely resembles that of an audio track on an AudioCD, it would follow that a VCD burned at high speeds would have the same kind of problems as I saw with the audio CD last week.

Since this thread began, I've been doing little tests here and there, and have found that if the disc is burned at a modest speed (4x or less), I can pretty consistently read it on any of the systems in the house, including standalone, EXCEPT, notably, MacOSX. I really think the CDROM drivers in X are broken when it comes to VCD.

As for the standalone DVD player you mentioned, it may very well be that it cannot read CDR/CDRW's. Sony players, for instance, have not been known to be terribly CDR-friendly. If you think about what businesses Sony is in, and the assault on fair-use rights that the MPAA and RIAA have been carrying out (hint - Sony is a member of BOTH organizations), there is some kind of perverse sense to the idea that their players won't read CDR/CDRW's. Or would that be overly paranoid??
 

jove

Member
I rerecorded with 8x speed.

iBook still runs fine

Windows Machine 1 can play it with QT but skips many frames. WMP has an unidentified error. We just think that CDROM drive has issues.

The CDs were sent out to family, so I'll soon find out how feasible VCDs will be.
 
Top