Please help fix Classic on a G3 PB

Hi!
I just spent part of yesterday installing 10.1 on a friend's Powerbook G3 (Firewire, keyboard looks fine to me). The install went fine (except could not register - no internet access at the time) and we installed the dev tools, and tried to run Classic (BTW his OS 9 is still 9.1). No go: it opened Classsic Startup, which gave a message to the effect of You do not have privelages to use /system/library/coreservices/classic startup
(note: this is not an exact quote). Also, when I checked the privelages for the System Folder (OS 9), it said that the owner was the guy's username, and even though he is an admin it said that group was unknown. I tried activating Root, we know the password we gave it, but it won't let you log in as root. It also appears to have added characters to his own password (when you go to Users PrefPane and count the # of *'s, the number was different than his password) but everytime he needed to enter his password to allow something, it worked. What's going on here? I just got this guy to go to X and now he can't use Classic, which he needs for many reasons. Please help!
Thanks,
~Ryan
 

francofranchi

Registered
I assume you have REINSTALLED system 9, and not simply kept the system previously existing. If so, did you check if your root password was correctly typed? Try resetting the root password (restart the Mac by the installation OS X CD and select the utility option fron the File menu as it opens up) with a different one. If this doesn't help, I'm afraid you gotta restart the installation from the scratch. Even so, before doing that, try to create a different user (with admin privileges) and see what happens to this one. I would also recommend you upgrade that system 9.1 to 9.2. If everything goes to hell, you can always talk to the 800 hotline number of Apple (there is a list of telnumb in their site). Good luck.
 

edX

mac shaman
1st password letter count is constant no matter how long your actual password - addded security. second go to osx system prefs and get your internet and network configured. get on and use software update to bring youself up to date. and/or get on net in 9 and upgrade to 9.2.2. install everything. (except the new printer drivers). try again.

it's not that you didn't register. i never did because i didn't want to go thru the internet setup again.
i also assuem your friend can still boot in 9 so he's more annoyed than out of luck.
 
Top