Poll: Installation of X on a beige G3

Zero

Mentos! The Freshmaker!
For those of you that have beige G3s, what is your experience with installing X on them? I found that the 10.0.0 CD I have (both burned copy and original) doesn't like the G3 FirmWare much, and I usually end up booting into the FirmWare manager and resetting the FirmWare defaults ("set-defaults").

Thanks in advance,

Jason :)
 

AdmiralAK

Simply Daemonic
What OS where you running previously ?
I believe that we had to upgrade our firmware on our gray desktop G3 for an OS before OS X.

I dont know about OS X yet because our dept. head doesnt want to install it yet.



Admiral
 

Zero

Mentos! The Freshmaker!
I'm running 9.1 right now, but I can't seem to find any FirmWare updates off versiontracker.com for my G3 outside of a small fix for some 24x CD-ROMs.
 

iamnoel

Oh no!
I've got an older beige G3 at work I'd like to install X on once it gets to be a fully valid option (i.e., there's a version of Office out for it, etc. I'm glad FileMaker's no longer an issue).

On the iMac I've got here, I obtained its Firmware Update via the Control Panel. Isn't that the logical order of things on beige G3's, too? I got the one I have in '99, & I've got no idea if I updated Firmware on it or not; but I've got 9.1 on it.

One way or the other, I'm guessing I'll not be installing X on it 'til later in the year.

Noel
 

Zero

Mentos! The Freshmaker!
I checked for a FirmWare update via the Software Update control panel; oddly enough, it said nothing was available for the Beige G3.
 

mapski99

Junior Mint
I have a rev1 Beige G3. Since the rom in this G3 only allows one drive per IDE channel (ie no slave drive support), I had to put in an apple SCSI CD-ROM in order to install a 2nd IDE HD. With the SCSI CD, OS X hangs everytime I try to run the installer. I get a nice kernal panic. Can't get past this.

My next step is to temporarily swap in an IDE CD-ROM and pull one of my hard drives. I will get back to ya when I get it swapped and report on my success or failure.

Another option for me is to upgrade the rom (I think OWC used to sell them with certain processor upgrades). Since I donated my IDE CD-ROM last year, I would have to get another.

+mapski99
 

Zero

Mentos! The Freshmaker!
Here's my configuration (drive-wise):

I use only 1 IDE device on this G3, and it runs off the first channel. The system also uses this to boot the OS.
I use two SCSI devices on this G3; one is a drive reserved primarily for a file server (SCSI ID 6), and the other drive is my Apple 24X CD-ROM (SCSI ID 2). Both are connected by one SCSI cable (it looks similar to an IDE cable, so would it be safe to say that the cable's self-terminating?), and plug into the SCSI controller on the motherboard.

I had a Mac tech tell me the other day that it was possible that extra SCSI devices on the G3 could be the cause of X not wanting to install, and giving a kernel panic message.

As a matter of fact, I'll try some different drive configurations, and I'll get back to you guys when I find out what works. :)

Jason
 

ezra

Super Organism
I have a beige G3 333 with DVD A/V option. Had all the usual problems installing the OS X beta. I was surprised when the shipping version installed flawlessly. I was happy with how things went, but I had a few quarks with Classic not wanting to start up. It froze during the start up and I had to hit the stop and got the warning. It would still be displayed, so I would hit stop again and it would close. Starting it again would start fine. I had to do this every time I wanted to use Classic environment after a start up. So, since I have three drives, I thought I would set one of them up with both X, and 9 on the same drive to see if it would behave better. In the procces I reformatted the OSX drive, so I could store some files on it while I was settings this up. I do a clean install of OS 9.1 using the CD provided with OS x, and all is well. After installing and setting it up, I then put in the X disk and clicked the install icon, and the machines reboots just like it did the first time, but this time it just hangs like it did with the beta? [scratching my head] This is odd it just worked fine earlier. Hmm, so I thought maybe I need to flash the firmware of the SCSI card again, so I do that, and get the same blank screen on reboot. Next I try reseting the motherboard, and it boots into OS 9. Hangs again on install. Next I set the firmware to "set-defaults." Still the same problem, so I get drastics. I remove all my PCI cards including the ultra wide SCSI card. At this point there is only my DVD ROM which the machine shipped with, and the built in video with personality card. No Hard drives, because I thought they may be the problem. I remove the battery, reset the motherboard, and boot into firmware, and set defaults. I type "bye" the machine boots to the ? disk, which I suspected. I insert the X CD, and it shows the happy mac icon, and reboots to the same blank screen. I think I pretty much covered everything, bit it still wont boot. The only other thing I can think of is to try and track down that firmware update mentioned in the manual, but I can't find it any where. It says some are on the OS X CD, but I find nothing. I'm also looking into the DVD ROM as a possible porblem. As far as I can tell OS X has done something to my machine that I can't get rid of, or need to get back. I'm not certain what it is, but any help would be much appreciated.

[ e z r a]
 

ezra

Super Organism
I just wanted to let everyone know that I solved this problem on my machines. I took many steps including snooping around with ResEdit. I found that certain machines have special boot strings in the installer, my machine was one of them. I narrowed the problem down to IDE, and then the DVD ROM, so I removed the DVD ROM, and replaced it with a Apple approved CDROM, and it booted X with no problem. I've always thought the DVD ROM was the problem, but didn't have a drive to swap it with until now.

If you have a machine with the ID of 510, this will most like solve your problems. It may also work on 314, and 312 machines. I don't have those machines to test, but they also had the special strings for booting.
 
Top