Poor HD Trailer Playback with Tiger

PeterPype

Registered
I am a video editor and I recently bought a PowerMac G5 2.0 GHZ MP 2.5 Go RAM 64 MB video card for my work.

I discovered that when I recently upgraded to tiger 10.4.1 all the HD trailers from the apple website don't playback properly
they dont play smoothly.
And I also discovered that the interface response of some applications like after Effect and other software are slower.

For example Apple recommends for the batman begins trailer in 1080 format a 128 Mo video graphics cart with a G5 2.0 Ghz MP, but when I played back even the highest resolution trailers in Quicktime 7.0.1 on Mac OS X 10.3.9 with my 64 Mo video card they all played back smoothly even when I doubled the size and played the trailer on both of my extended 19" screens at once.

I also had a lot of problems with the firewire video preview
on my Canopus ADVC-100, I had to completely reinstall Quicktime 7.0.1 and then it worked again.

I am sure that Tiger eats a lot of processing power for the 64-32 bit compatibility and for other stuff.

I have even done a clean Install of Tiger and the HD trailers still didn't play back smoothly
Then I clean installed MAC OS X 10.3.9 and everything played smoothly.

I think Mac OS X 10.3.9 doesn't have the 64-32 bit problem so maybe its because of that?
I dont know but its unacceptable that tiger slows everything down even with After Effects render
or HD playback.

I plan to downgrade to Mac Os X 10.3.9 unless someone has a good tip !
 
Top