Power Mac G4 Dual 1 Ghz Mdd Audio Input/output Problems Since 10.3.6 And Sleep Problem Since 10.4


Hello, I'm using a Power Mac G4 Dual 1 GHz MDD, with 1.25GB RAM, 4 internal hard drives, PCI slots filled (USB 2.0, PCI slot fan, 10/100 Ethernet, SCSI/Serial), and OS X 10.4.2.

First, the audio problem. Ever since OS X 10.3.6 came out, my computer has exhibited the audio distortion problem (after every restart, the actual audio increases, even though the computer still displays the same volume level as before the restart). The temporary fix was to unplug and the replug the speakers from the audio output port, after which the the volume level would jump and display the actual volume level (3 notches higher on the bezel volume display which pops up when you press the volume keys on the keyboard). A slightly less-temporary fix was to replace the Apple02Audio.kext (in System > Library > Extensions) with that of 10.3.5. At each OS update, I would replace the .kext with the latest one and then run the update, but to no avail. Even replacing it with the .kext from the combo update didn't help; the audio bug persisted, so I kept using 10.3.5's Apple02Audio.kext. I was afraid that the lack of an improvement all the way up to 10.3.9 would mean 10.4 might not fix anything on that front. I was right; installing an archive & install of 10.4 didn't fix the volume problem. Now I'm running 10.4.2, and the bug is still there. Is there something wrong with my built-in audio processor (the TAS3004)? It's odd that the problem occurred right when 10.3.6 came out, which is when other MDD and certain iBook users reported the same problems, only theirs seem to be fixed by now since I haven't read any complaints about it recently.

Today, I was recording some audio from a tape player, which I did only a few weeks ago in the same manner, when I ran into another problem: the audio in starts to echo and distort after a random amount of time. I tried different audio sources and different recording programs, all with the same result. At first it happened after about 20 minutes, then after 4 minutes, and now it occurs after only about a minute of recording. This never happened before, despite using the exact same equipment with the same settings (though of course I tried different ones after the problem showed up). I'm wondering if this could be related to the audio output volume problem, but it seems odd that the input would have problems so much later.

The second (or third if you count audio in/out separately) problem: Since upgrading to 10.4, my system has been unable to sleep. No hardware has changed from 10.3.9 to 10.4, only the system. Should I be attempting to find fault with a PCI card? When I tell the computer to sleep, the video signal shuts off, the fans go into a low spin, and the power light dims slightly (and remains constant), but the computer doesn't actually get to the sleeping part. From what I can tell, the drives are still running as well.

Thanks so much for any help with this lengthy report!!