Power Mac G5 Will Not Wake From Sleep, Fans Blowing Full Blast

matthewboyd

Registered
I just bought a new dual 2.0 ghz power mac G5 about 2 weeks ago. I set everything up and dowloaded all the updates for everything, and then about a week into using it the problem started. I left for work and when I got home that evening after the computer had been asleep all day, it sounded like the computer was taking off from a runway. It would not respond at all to the keyboard or mouse so I had to shut it down by holding the power button on the front of the unit and then start it back up. I called tech support but they had me turn the option off that puts the harddrive to sleep when possible and then turn off my screensaver. Well it was fine again for about a week and then it happened agin yesterday, not once but twice. I looked on apple discussion boards and there is alot of this happening. Well I took one guy's advice that seemed to know what he was talking about. I restarted holding the command-option-o-f keys down, then prompted the computer to reset the v-ram, and two other things he suggested to reset that I cannot remember. Then I restarted, trashed the energy saver prefs and ran a repair disk permissions task inside OSX. Well that is where I am now, and it has not done it again, but I am still trying to find out what exactly is going on here. I just spent $2000 on a machine and it appears messed up and Mac has no answer. Your help would be much appreciated.

Thank you,
Matthew
 

Eolake

Registered
Matt,
I can't help, I am in the exact same situation as you. Except my dual 2.0Mhz is two years old. When it was new, it did it. And the "turn the option off that puts the harddrive to sleep when possible" thing helped. But after newest OS upgrade, the problem is back. C'mon Apple, we know the upcoming Intel machines are priority, but I think G5 users deserve some service still! Solve this bug.
 

Mikuro

Crotchety UI Nitpicker
The same thing happens to me with my Mac mini. I haven't really nailed down a cause/solution, but here are a few facts of my situation, which I hope you'll find helpful:

1. The problem began shortly after I upgraded my memory from 256MB to 1GB. This was the same time I had my logic board replaced (my original one couldn't handle the gig of RAM for some reason), and a week or so after I began using a LaCie FireWire DVD±RW (I wanted to back up my whole system before doing any upgrades, naturally).

2. It only seems to happen when I put it to sleep by hitting the power button. It's never happened when I select "Sleep" from the Apple menu (although I haven't done this enough to prove it conclusively; what is your experience with this?).

3. It IS possible to wake it up when this happens — just not through normal means. I found FOUR ways that each sometimes work. They are:
3a. Hitting the power button on my mini again.
3b. Hitting command-control-power on my third-party keyboard (which normally forces a restart).
3c. Unplugging my USB game pad from my keyboard (or pluggin it back in if it's not in to begin with).
3d. Turning on/off my LaCie DVD±RW.

That's all I know. It seems to me like it has something to do with my external devices (DVD±RW and/or game pad). I normally keep my DVD±RW off when not in use.

Does any of this match your situation?

For now, I always wait to see my Mac mini's power LED start its sleep pulse before I leave the room. If that doesn't start in a second or two, I know it's not really going to sleep, and I try to snap it back awake and start over. I've never had the problem happen twice in a row.
 

jellyrollo

Registered
Tutorials
Tuesday, March 01 2005 @ 03:30 AM PST
Tutorial: Dealing with Wake-from-sleep issues
These fixes deal specifically with the two most common wake-from-sleep issues affecting Mac OS X systems -- a completely blank screen with the system unresponsive where a forced restart is usually the only option and a kernel panic where a restart is also required.

Both manifestations of these issues also exhibit the following symptoms:
* The afflicted machine does not react to a network ping.
* The CD works normally and will accept media, but the system does not react appropriately.
* The battery continues to drain
* The machine does not "Wake for network administrator access"



Do not connect, disconnect external devices during sleep Avoiding disconnecting or connecting external devices -- USB, FireWire, etc. -- during sleep eliminates this issue. It also appears that, in some cases, all external devices must be disconnected before putting the machine to sleep.

Several readers have since corroborated this workaround.

MacFixIt reader Philip writes "Removing devices when the computer is sleeping (USB Serial) has usually caused the computer to hard crash in the kernel more times than it has fixed anything for me. My advice -- if putting the computer to sleep and about to say go home -- remove devices before computer goes to sleep."

Another reader adds "If I unlatch the screen and open it without plugging anything in, it works immediately. If I plug in the power cord, a FW drive, a USB anything and then open the screen, the screen is usually blank and the machine is unresponsive."

Finally, yet another reader writes "I zapped PRAM, reset the PMU, and followed all of the fixes reported except reinstalling with no results. Unplugging the USB devices however provided a foolproof fix. To sleep I unplug the USB and use the touch-pad to sleep from the menu. It has slept as long as 14 hours and still wakes perfectly. I suspect the culprit is my Microsoft wireless mouse."

Close the lid again and wait In the case of some PowerBooks, simply closing the system's lid, waiting a few seconds, and re-opening the PowerBook allows proper wake-up. Reader Joe Samuels confirms: This has happened from time to time to me. I have a 15" Ti-Book. I have always been able to fix the problem by closing the lid, making sure that the catch is holding the lid, waiting until the sleep light comes on and then re-opening the lid. The machine wakes perfectly and quickly each time.

"Each time it has happened, I have unplugged peripherals with the lid down, or plugged in peripherals with the lid down, so I try to remember always to plug and unplug with the lid up. Even when I forget to do the plugging and unplugging with the lid up, the problem does not always occur."

Disabling Network activity before sleep Terminating all network activity -- in some cases necessitating a power-down of the AirPort card or disconnection of an Ethernet cable -- is, in some cases, particularly effective at eliminating the "blank screen on wake-up" issue.

George Greene verifies "Each time I put the PB to sleep, I make sure that there are no network processes running; ergo network activity, mail checking etc.

"I observed that there was a correlation between my e-mail checking for new mail through my Airport as I was closing the lid and the sleep coma.

"Since then I have verified that my Airport is off and inactive prior to putting it to sleep, no issue"

Re-installing Mac OS X Though it is the most tedious of the workarounds, it may also be the most consistently successful. Several readers report that re-installing Mac OS X via an Archive and Install process, then updating to their previously installed Mac OS X incremental release (or the release before they started having wake-from-sleep problems) has resolved this issue.

One reader writes "I finally got around to completely reformatting and reinstalling Panther, and all the apps, and it has been one month now without even one occurrence. We'll see if it starts happening and gets worse again over the next few months. But I hope it is finally fixed."

Another adds "I wiped the drive clean and did installed Panther from scratch about 2 months ago and haven't seen the problem surface yet. Maybe this did it. I still make sure I save my work before closing the lid to be on the safe side."

Checking for Bad RAM Faulty RAM may be the culprit of your Wake-from-sleep issues -- especially if distorted video is present.

You can easily determine if you have a "bad" RAM module by using the Apple Hardware Diagnostic CD, included with all currently shipping Macintosh models. To use the Apple Hardware Test CD, restart your computer while holding down the C key until the "Loading..." icon appears.

Note that the Apple Hardware Test can not be used when a mouse is directly connected to the USB port on the display or on the iBook. Apple says "Please connect the mouse to a USB keyboard."

You may also want to try removing each RAM module one-by-one and checking for persistence of the problem.

One reader writes:

"I have a PowerBook G4 15" 1.25Ghz and attempted to add house-brand RAM from CompUSA. I got two 512MB SODIMMs marked "PC-2100/2700." The RAM caused an initial crash on boot and then a kernel panic, but after that I was able to restart and use the new RAM fine, as long as I didn't put the machine to sleep. Doing some research, I saw Kingston recommends PowerBook users turn off processor cycling ('highest performance' rather than 'automatic') for their RAM, and this seemed to help. With 'performance' on highest, I was able sleep the PowerBook and wake normally, but only if it had a power supply connected. If it was forced to run off battery power while asleep, it would not wake up. Apparently, for RAM to work in recent PowerBooks, it needs to support a low power sleep state. Most cheap/generic RAM brands don't do this, even though they claim PC2700 status and list the same specifications. Kingston, for example, has as least three different models of 'PC2700 SODIMM RAM,' all of which have the same specs but are designed for different models...A client had a similar problem with 3rd party RAM in a 17" PowerBook using PC2100 RAM. Appeared to work but always died in sleep. After biting the bullet and buying a Samsung 1 GB RAM SODIMM, I've had no problems with sleep."

Manually putting the system to sleep Putting the system to sleep via the Apple menu rather than closing a PowerBook/iBook lid or pressing a desktop power button (on appropriate systems) -- can work to avoid these issues on some systems.

MacFixIt reader Liz Beck writes:

"I thought you might find it interesting that I avoid the sleep problem with my 12" G4 PowerBook by putting the PowerBook to sleep (using the sleep command, not closing the cover) and then waiting until the external monitor that I connect it to is totally asleep (amber light instead of green light on) before disconnecting the PowerBook. When I do that I have no problems with sleep issues."

Deleting specific .plist files In some cases, you can resolve Wake-From-Sleep issues by deleting the following property list (.plist) files:
? /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist
? /Library/Preferences/SystemConfiguration/com.apple.AutoWake.plist
? ~/Library/Preferences/com.apple.systemuiserver.plist

After deleting these files, restart and check for persistence of the issue.

Never allowing the system to automatically sleep In some cases, never allowing Energy Saver's timer to put a portable to sleep has similar positive results. This is accomplished by accessing the Energy Saver pane in System Preferences, clicking on the "Sleep" tab, and sliding the "Put computer to sleep when it is inactive for:" bar to "Never."

Jan Morren corroborates "I just wanted to add something to the 'failed waking from sleep' issue. I'm a System Administrator at a large laboratory, and we've been suffering from this issue. But there is one thing that seems to make things work again: We have about 120 Macs in the network, and on every machine where this issue appeared, I turned off the ability for disks and monitors to sleep separately, and I put the lever for automatic sleep to 'Never' in Energy Saver. People now have to put their machine to sleep by themselves. The problem never appeared again."

Turning off all Wake/Other options in Energy Saver Some readers report that turning off all special automatic sleep options has resolved this problem. This can be accomplished by entering the Energy Saver pane of System Preferences, clicking on the "Options" tab, then unchecking all options, including:
? Wake when the modem detects a ring
? Wake for Ethernet Network administrator access
? Restart automatically after a power failure

One reader writes "I called Apple Tech Support back the day (Dec. 10) your latest article on this issue came out. [...] After I mentioned your article, and he told me that he had handled several calls on this problem. He said the following workaround had worked consistently to fix the problem: Open the Energy Saver preference pain and click on the Options button; Uncheck every option in the Options section, then close System Preferences."

Another reader found success by turning off the "Put the hard disk(s) to sleep when possible" option, which is located under the "Sleep" tab of System Preferences:

"Apple Support suggested that I uncheck the 'put HD to sleep when possible' box in the Energy Savings prefs and I never let it put itself to sleep."

Turn off "Allow Bluetooth Devices To Wake This Computer" Several users have reported that turning off the option to allow Bluetooth devices to wake their Macs (located in the Keyboard/Mouse pane of System Preferences) allows normal wake-from sleep activity.

Setting processor performance to "Highest" In another Energy Saver-related workaround, MacFixIt reader Dan reports that setting processor performance to "Highest" using Energy Saver (in the "Optimize Energy Settings" pull-down menu) has eliminated the issue on his portable:

"I had not seen this problem on my 6 month old AL 15" PowerBook, but I have always had it set on "Highest" processor performance. After reading these articles, I tried setting the processor performance to "Automatic" and the first time I put the PB to sleep (closing the lid), it failed to wake up. I closed the lid again, waited a minute, and it woke up cleanly. I have now set the processor performance back to 'Highest' and have had no further problems. I have 1 GB of factory-installed memory."

Reset the PMU Resetting the afflicted Mac's PMU (power management unit) can sometimes resolve this issue.

MacFixIt reader Jeffrey writes:

"Just to let you know. I had problems waking up my new G5 iMac (20 inch screen) I just got. I have the screen save to come on after five minutes which it does. But after about a half hour or so, I'll walk away and come back and my computer will be sleeping. Which I found odd, because I had my settings in the Energy Save pane set to 3 hours for the display and the hard disk. When I try waking it up, it would not. I talked to Apple and they were wondering if the light was pulsating on the front of the iMac monitor. And it was not. Right away they told me I would need to reset the PMU. Happy to report, it worked. The problems no longer occur, and its been over a week. I am also very happy to see that Apple resolved the issue in less than five minutes. Impressive."

Instructions for resetting the PMU for various Mac models are contained in the following Knowledge Base articles:
1 Mac Mini
2 PowerBook and iBook
3 Power Mac G5

Resetting NVRAM via Open Firmware A number of users report that resetting NVRAM resolves wake-from-sleep issues.

In order to perform this process, hold down the Command, Option, O and F keys at startup. When the prompt appears, type:
* reset-nvram (then press return)
* reset-all (then press return)

One reader writes: "The technician led my friend through the same PMU and PRAM/NVRAM resets that he had just performed ... but then did not let him stop there. He also insisted that the NVRAM be reset from the Open Firmware screen prompt

"This solved his problem! His new iBook G4 now wakes from sleep each and every time."

Not setting a logout interval MacFixIt reader Jonathan reports that not setting an automatic logout time in the Security pane of System Preferences resolved wake-from-sleep issues on his system:

"I also had this wake from sleep issue with a G5/1.6 running OS X 10.3.8. The screen would go black after a period of time and only a manual restart would work. The solution was to uncheck the 'Log out after xxx minutes of activity' in the Security panel."

Do not Disconnect power during sleep Avoid disconnecting or re-connecting a PowerBook or iBook power source during sleep.

One reader writes:

"I believe that the problem may be related to a change of power state between the time the machine [Powerbook 12" 1.33GHz] went to sleep, and when it was turned back on. Specifically, if I sleep the machine when it is running on battery, then plug in the power adapter, then attempt to wake it by opening the cover, I believe I can increase the likelihood of a panic on wake. So far...only when there has been a change of power source has there also been a crash on wake."

"Slowly" putting PowerBook/iBooks to sleep MacFixIt reader Wally Dixon was able to workaround this issue by "babying" his portable when it is about to enter sleep mode. He describes:

"Here's how I 'baby' the PowerBook: in the office I'm connected to a monitor, AC power, USB keyboard, mouse, etc. I unplug everything, especially power, and then kind of loaf for about 10 seconds before closing the lid. I always close it 'active' i.e. no screen-saver or not already asleep. I don't plug anything back into it until I wake it up again.

"Part of this stems from a theory that the PB might get confused if you sleep it in one power state and wake it up in another power state (i.e. on AC vs on battery) so I 1) make sure it's in the same state when it wakes as it was when it went to sleep; 2) give it time to figure out the new state when I unplug or plug in the AC. [...] Seems to have helped a lot."

Garbled Displays on wake For coverage of an issue where various systems display a distorted screen image -- a scrambled version of the expected image or a series of random blocks -- when waking from sleep, see this article.
 

David Paisley

Registered
From reading this discussion thread, I tried a bunch of the fixes proposed in it. I discovered that by ejecting the two USB 2.0 hard drives from the USB 2.0 PCI card (yes, I have the last model PowerBook that didn't have USB 2.0 built in) and then powering down the card, my computer would go to sleep, and when it awakened, it would turn the card back on and there would be my two hard drives. Now, the only thing that remains for me to discover is some sort of automated routine that will perform the ejecting and powering down tasks when it's time for my computer to sleep. Any thoughts?
 
Top