Powerbook G4 Superdrive Problems



I have had my Powerbook G4 1GHZ/ 1GB RAM / 60 GB HD / Superdrive / MAC OS X 10.2.1, Dulal Boot OS 9, since November 2002.

I recently upgraded to 10.2.8 using the Combo Updater from Apple's website.

The Powerbook, was working fine until the update.
Now the Superdrive does not function properly. On insertion of a Disc it whir's for a while then spits out the disc. I managed to get a commercial DVD to read, and a commercial CD to read, although later on they were also spat back out. Ialso managed to insert a CD-Rto burn some files to see if it would work. Curiously it said the maximum burn-speed was 8x 9when it used to be i think 52x). Anyway, burning didn't work, it spat the CD-R out as well.

I don't think that it could be a hardware problem, as it only happened after ugrading. Cleaning the Superdrive witha lens cleaner hasn't worked either.

I have tried various solutions, repairing privileges, resetting PRAM etc, using third party clean-up software (Yasu). Nothing has worked so far. I have had a look at the System Profiler and the Matshita UJ-815 DVD-R drive is there fine.

Any help please? I am very worried, and really cannot financially afford a huge repair bill.

Many Thanks
(a very anxious).. Pavan Verma
hmmmm... new firmware. Its worth a shot.

I will give it a try and let you know.