Powerbook Will Not Boot

Steve_C

Registered
Hi all,
I have a G4 powerbook (Ti), on which just installed a recent safari update, but when I tried to perform the obligatory restart, it didn't. Now it just hangs on a black screen. The sleep light does not turn on at all. The CD tries to spin, but eventually it loses interest and just sits there. I have tried to start from the OS X install CD, but it doesn't respond (and of course, now I can't get the CD out). I have tried to flash the PRAM, but I never get an chimes. I've tried to reset the PMU, to no avail. I've also tried to run it as a targeted firewire drive to a G5 tower at my workplace, no luck. Help me!
 

Zammy-Sam

Desertchild
Hi steve and welcome to the forum.
Let me ask some simple questions first: Is your powerbook plugged to the electricity? Can you hear your CD-drive starting up once you press the on/off button? Did you hold the 'C' key to boot from the CD? Where you able to boot into the single user mode holding apple+'s'? Did you recently add any new hardware (e.g. usb devices)?
 
Top