PPP Connect is a mess! Who is smart enough to help me?!

Gavin Smith

PPP Connect gives me no end of problems. I'll try and list it all as clearly as possible and hope some of you guys can help me with any part.

I enter all the correct info into PPP Connect (including DNS servers). I click the "connect" button - nothing happens for about 20 seconds and then eventually the mouse pointer turns into the spinning CD (or that's what it looks like to me!) After that, it eventually does dial out and connects. All goes well for (on average) 10 minutes - I can email, surf the web etc - and then suddenly one of two things happen. Either the connection seems to fail (although PPP Connect does not report that I have been disconnected) - this is backed up by the fact that packets are no longer been sent or received according to PPP Connect. Or, again the connection seems to fail (i.e. I can't access websites etc) but this time the packet send and receives go mad, especially the receives. Although this would suggest that I am receiving loads of packets, I'm clearly not, as the net connection is dead. In either case, if I open up the console I eventually get failures for the DNS servers. The DNS servers are correct - just in case, I have now tried 5 different ISPs, each time entering the information carefully. The absolute maximum I have been connected for is an hour, but it averages at around 10 minutes. If the DNS servers were incorrect, surely I wouldn't be able to pull up webpages at all, not just for the first 10 minutes! When I hit the "disconnect" button, the spinning CD returns and it takes around 5 minutes before I can attempt to reconnect. My net connection worked flawlessly in OS 9. I have even tried wiping the disk, and reinstalling OS X PB with no improvement!

Please help if you can! As I'm you understand, without a decent net connection, OS X PB is useless to me :(

I am running a Power Mac dual G4/450 with 128 meg of RAM.