Printer Setup Utility unexpectedly quits everytime- Please Help

Thanks in advance. My OS is 10.3.5 and Printer Setup Utility 4.0

I cannot add any printers to my computer because everytime I try to open the Printer Setup Utility application, it immediately quits and gives the "unexpectedly quit" error message.

The following is the error message from the Console:

dyld: /Applications/Utilities/Printer Setup Setup Utility Undefined symbols:

/Applications/Utilities/Printer Setup Setup Utility undefined reference to _CPLCopyGenericPPDURL expected to be defined in ApplicationServices

I have tried almost every suggestion found on this and other sites:

I have archived and installed Panther again, no worko

I deleted the in both the user and HD library preference folders

I have run the Disk Utility repair permissions

Nothing so far has worked.

Tidbit of Info: I had Tiger installed, but took it off because it was crashing too much. Could this be a factor.

I would really really appreciate some advice on this matter. I can't live without being about to print.

Thank you, thank you very much. :)


In Geostationary Orbit
I am no print guru. however I have had several print problems along the Panther way. However a little shareware program Printer Setup Repair (just look down the page for the Panther edition). This little program has fixed my Network printing problem many times.


Hey, I also have the same problem, just on a 10.3.9 OS. The program you suggested did not help me at all, the program itself can't run properly. Does anyone else have any other suggestions? I have no idea where to begin, for example what files may I delete in my library and so on....



i had the same problem when i "downgraded" from Tiger to Panther. You need to delete your current Print Center 4.0 and then restore the Print Center from your Panther Software Restore discs or simply Install Panther again. Same thing happened to me with Safari and Ical. no way around it. just delete problematic apps and install Panther again. Archive and Install is the preferred method.

Hope this helps...