Printing Problem

pblock

Registered
Can someone give me some tips on getting my printer to work (or let me know if it isn't going to work under OS X)? I have an HP Laserjet 6MP on a beige G3 that uses to old standard printer port (not USB) and requires Appletalk to be turned on under OS 9. I was unable to get it to work, so then I made sure that Appletalk was turned on under the Network system setting. Still no go. Next I went into my OS 9 system folder and copied the HP Laserjet 6MP printer description file into the OSX/system/library/printers/PPDs folder on the OSX partition. Still no go (I can't print either from an OS X native application or within Classic environment). When I go to the Print Center, it says I have no printers available and do I want to add one. No matter how I try to add one, nothing works. Under "Directory Services" the add button is grayed out. Under Appletalk nothing works. Under LPR it shows my printer model and asks for the address. What do I put there? Is there an address for the standard printer port? Any help will be GREATLY appreciated.
 

BobB

Registered
I also have an upgraded beige 266 MHz G3 MT (now with 224 MB RAM, 500 MHz OWC zif chip) and a LaserWriter 8 compatible printer (GCC BLP Elite) connected to the standard printer port via AppleTalk.

I can't print a thing from Classic or MacOS X.

Were you able to get your HP to print? If so, what did you do?
 

LunaMorena

Registered
The serial port (printer/modem) on the beige boxes is not supported under OS X. you need to use either a USB printer, a network printer (appltalk and LPR both work), or just print from classic. The way to do the last of these is to do a print preview, save the preview as somethingoranother.pdf, and then open THAT file up in Acrobat Reader under classic and print from there.
 

postlandcj

Registered
I too am having troubles printing.

Printing from OSX to an ethernet-bridged Laserwriter NTX produces Poscript errors.

In the OSX print dialog box I chose the Format for "Apple LaserWriter II NTX". After I hit Print I get an error that reads: "This print job failed due to a printer PostScript error (undefined)".

When I print from QuarkXpress (in OSX, under 9.1) I select "Apple LaserWriter II NTX" under the Page Setup...Setup...Printer Description. The page prints! BUT it's not setup correctly on the page. The type that's at the top of the page in the document, prints about 3 inches down the page. This also happens when I print using the "Generic B&W" driver.

Does this offer any insights to my problem?
 

lmobrien

Registered
I'm using a G4 (AGP) with my old Laserwriter Select active via AppleTalk Laserwriter Bridge running on an OS 9 beige G3 Mac. Printing works normally in OS X (or at least as normal as it does in OS 9). Had to turn AppleTalk on and add the printer (which took almost a minute to recognise the printer connection).

As for LPR, that's for IP printing. You'd need a printer server setup and the address (135.53.12.12 or whatever) you put in is the one for that server (usually another Mac or NT box).
 
Top