Printing to Hp 1200se On Os 10.3.9


Since applying the Apple OS update from 10.3.6 to 10.3.9 and security updates, I can no longer print to my HP 1200se printer via USB cable. This worked fine before the update. I had to reinstall my VPN client software and reconfigure my internet/Airport connection settings, so I thought re-downloading and reinstalling the printer PPDs should solve the problem. But the unstuffed HP installer program hangs at the point of searching the hard drive when I try to reinstall the files and I have to do a forced quit. I can delete the printer from the list and add it back anew, and it is recognized in the System Profiler as an HP 1200se, but when I try to print to it I get a message of "waiting for device", even when it's clear there is nothing else in the print queue. My HP psc1315 inkjet printer still works, but the laser printer will not. It's not the 1200 printer or cable, as it works with our (yuk) PC just fine. I'm hoping it's a simple problem that you will be able to solve easily. Any suggestions you have would be greatly appreciated.
Thank you.
By the way, this is close to the limit of my technical level, so don't be afraid to patronize me.
CHeck the HP site for updated drivers that support 10.3.9. It could be that the drivers you have are too old for 10.3.9.

Nevermind, you already did that. :p

Have you tried repairing permissions? Go to Applications-->Utilities-->Disk Utility and select to Repair Permissions. Then try and reinstall the 1200se drivers (if it's a dmg file, make sure you copy the contents to your Mac HD once you've mounted the drive image.).

If you install the drivers from the mounted drive, chances are the drivers haven't been installed and it's still using the older driver.
Thanks for the idea, Nixgeek, I think you hit the problem on the head. While poking around on the HP site looking for options other than the very old (May 2002!) PPD "update" files that wouldn't install to my machine, I saw that this printer model has been discontinued even though it's less than 4 years old (what is that, 100 in computer years?). And the CD that came with the printer only went to OS 9... So I'm suspecting that they're NOT going to make an OS10.3.9-compatible PPD for that printer, just so we'll be forced to buy a new one. Or upgrade to Tiger, even though I don't really need any of the new features of 10.4. My only hope, unless you have any notion of where to get an updated PPD, is to try to reboot my computer in 9.2 (she's a dual-boot) and see if that driver still works.
Thanks for your time, I really appreciate the ideas.
I seriously doubt that such a minor update would render your print driver obsolete. However, MacOS X 10.4 comes with a new driver for your printer. I would suggest that you delete your old printer setup and do a new one.