Printing with GCC printers...

maxebb

Registered
I have an Elite XL 20/1200 GCC laser printer (www.gcctech). They claim it works with OS 9.1 and OSX but I am still completely unsuccessful printing anything under classic applications. Believe me, I've tried everything to get it to work. I've been back and forth with tech support and have given up.

GCC says it will provide new drivers for OSX, although it does print with OSX- with most applications already.

max.

G4 450 500ram.
 

ducky

Registered
I'm printing to a GCC 1212 and seem to be having the opposite problem. Whenever I print from a Cocoa application all I get is a black page. When I print from classic or a carbon app I get a proper printout. I've tried putting the PPD's in every PPD's folder I could find and still have the same problem. If anyone has any ideas I would be most grateful.

 

maxebb

Registered
well here's a wild shot, I did set up my printer with OSX before I setup the OS9. In X The Preview app prints fine.. printing from a browser is fine.. but I get black blocks when printing from sticky notes.. So i wait for the driver.

What did you do to set it up in OS9.1?

max
 

ducky

Registered
To set up the printer in OS 9.1 all I did was put the ppd in the ppd's folder. I've tried to do the same in OS X but it dosn't work. :eek:(

I get the Black Boxes whenever I print out of a Cocoa app. for example, when I print out of OmniWeb I get the black blocks, but I can print out of IE no problems. Oh well, waiting for a driver.
 

maxebb

Registered
Suitcase 9 MenuFonts is NOT compatible with OS 9.1 That was the reason why I couldn't print with Classic applications. Disabling it from the extensions is all I needed to do. I'm now printing fine with 9.1

GCC suggested I use Adobe Post Script (download available at Adobe's site.) rather than LaserWriter 8. I haven't tried this with OSX, but it doesn't matter, it's not a OSX application.

GCC plans on releasing new printer divers for OSX this or next month.
 
Top