Perhaps I haven't explored the administrating capabilities of OS X well enough, but very often when I try to empty the Trash, I get a message saying that I do not have privileges for some of the items. I have tried changing the privileges under the "Show Info" window to Read/Write. I've also tried checking the "Ignore Privileges on the Volume", but this doesn't change anything.

There doesn't seem to be a rhyme or reason to which files will not erase.

Any suggestions?
Okay, here's the deal, yo:

You can change anything and everything in your user folder. I'm pretty sure not much else.

If you're an admin, you can change things in the applications folder, and I believe other user's folders. You can change things in the Library folder. You cannot change things in the System folder.

If you're root, you can change anything, everything, and all things, anywhere. This is why people say that root is so powerful, because there is nothing stopping you from typing "rm -rf /" in terminal and hitting enter. (Don't type that in terminal as root, it'll erase your drive)

I think that covers it. Hope I haven't confused you more...
Thanks for the help!

I can see how the root could be powerful, but I'm just not down with the UNIX lingo yet (Give me a couple days!).

The thing is that they are just regular mp3 files from my Computer directory. I also tried moving them to my User directory, then deleting, but that didn't work either.

Of course, when all else fails, I've been booting up into Classic, then emptying the Trash works fine!

Is anyone else having this problem?

Thanks in advance for any help,