Problem Changing Preferred Language to Arabic

nidhi

Registered
Hi all

I have a problem running my application after changing my language setting to 'Arabic' thru System Preferences. My application(written in C-C++) is not able to read a simple properties file (ascii) which contains Port information. I'm not able to understand why this is so. Is it something to do with file naming convention when changing the locale to Arabic????

Thanks & Regards

Nidhi
 

lurk

Mitä?
Are you sure that the file is ascii and that there are no Arabic characters in it? If you have edited the file and accidentally changed it into Unicode for instance that could cause you problems. You can use the command 'file' to see a likely guess about what the system thinks in in the file for instance I have

Omppu:~ eric$ file foo.cpp
foo.cpp: ASCII C++ program text

Hope that helps.
 

nidhi

Registered
lurk said:
Are you sure that the file is ascii and that there are no Arabic characters in it? If you have edited the file and accidentally changed it into Unicode for instance that could cause you problems. You can use the command 'file' to see a likely guess about what the system thinks in in the file for instance I have

Omppu:~ eric$ file foo.cpp
foo.cpp: ASCII C++ program text

Hope that helps.
Hi

Thanks for the suggestion. I tried the 'file' command to look at the file. I got the same result as above "Ascii text". My file contains the following info :

filename 'DBserver.properties'

DBserver_host= IPAddress
DBserver_port= 5432

The same file is read without any problems when the locale is "English" but when I change it to Arabic i get the error "Cannot find file DBserver.properties...."

Could you suggest me any other work-arounds?

thanks & regards
Nidhi
 
Top