Problem compiling sawfish


I am trying to compile sawfish and I get that error:

/sw/include/libgnomeui/gnome-druid-page-finish.h:22: gtk/gtk.h: No such file or directory
sawmill-capplet.c:43: gdk/gdkx.h: No such file or directory
make[1]: *** [sawfish-capplet] Error 1
make: *** [all] Error 1
### make failed, exit code 2
Failed: compiling sawfish-0.99-1 failed

Anybody know where I can get that header file?

I know that this might come as a surprise to everyone, but I would highly suggest using Fink. If you type

fink install sawfish

it will determine what you need and download and install that for you.

I had no problem installing Sawfish 0.99. In fact, if you get the latest CVS snapshot, you can be the coolest person on your block and have Sawfish 1.01.

-Bruce Adcock
I tried fink and it did not work. I then tried to install it by myself and it didn't work either.

howardm4: according to fink, all the required files are installed... From your [sarcastic?] message, I gather that the problem is coming from one of these 3 requirements so I will reinstall everyone of them and try again...

I was refering to Sawfish 0.38 which was a PITA
to compile for Darwin. Apparently, .99+ is alot better in
that regard.

If you say you have the include files, the compiler doesn't
agree w/ you. You need to see where the includes really are
and if that jives w/ what -I<directory> directives are being sent
to the compiler. All of mine are rooted at /usr/local/include.