Problem with mysql and os x.1

3mors

HampCake Studios
I have already written a post like this in os x server section as my problem is about server version, but I didnt receive any answer so I decided to post in this section.

So, dear moderator, don't move this post please.

Now, my problem is this:

I have os x 10.1 server and I want to use mysql.
Mysql isn't activated so I have to use mysql_install_db,
right?
But when I use this command, the system answers:

Sorry, the host 'PowerBook' could not be looked up.
Please configure the 'hostname' command to return a correct hostname. If you want to solve this at a later stage, restart this script with the --force option


Powerbook is the name of my computer

What I have to do?
On my previous os x 10.1 (not server), I installed mysql and it worked perfectly.

Thanx,
 

sebhoff

Registered
I'm not running OS X 10.1 server so I don't know what the procedure with the pre-installed version of mysql is - have you checked the mysql mailing list archives?

Here's what's in the mysql manual - this is relevant for linux but maybe it solves the problem for you.

Hope this helps,
Sebastian


If you are using a `libc'-based system (instead of a `glibc2' system),
you will probably get some problems with hostname resolving and
getpwnam() with the binary release. (This is because `glibc'
unfortunately depends on some external libraries to resolve hostnames
and getpwent() , even when compiled with `-static'). In this case you
probably get the following error message when you run
`mysql_install_db':

Sorry, the host 'xxxx' could not be looked up

or the following error when you try to run mysqld with the `--user'
option:

getpwnam: No such file or directory

You can solve this problem in one of the following ways:

* Get a *MySQL* source distribution (an RPM or the `tar.gz'
distribution) and install this instead.

* Execute `mysql_install_db --force'; This will not execute the
`resolveip' test in `mysql_install_db'. The downside is that you
can't use host names in the grant tables; you must use IP numbers
instead (except for `localhost'). If you are using an old *MySQL*
release that doesn't support `--force', you have to remove the
`resolveip' test in `mysql_install' with an editor.

* Start mysqld with `su' instead of using `--user'.
 

3mors

HampCake Studios
So I have to do as I have already done:

to install a new version of mysql.

Right?

However, thanx.
 

sebhoff

Registered
Originally posted by 3mors
So I have to do as I have already done:

to install a new version of mysql.

Right?
well, it says "in one of the following ways"...

Since you are surely in possession of a regular, registered version of OS X Server, you could ask Apple for some help? ;-)
Sebastian
 
Top