Problem with remote desktop connection

dfemorton

Registered
I have been having an authentification problem with ARD.
I have been using VNC but treated myself to a copy of ARD and I am very impressed with it.
However a few days into using it I stated getting Authentification problems:

NOTE:connecting to a machine running OSX server 10.4.3 from a workstation running 10.4.3.

I would double click on the machine as usual and I get a "failed to authenticate error message"

No settings were changed, the ARD client settings on the server in sys prefs are set to full rights for an administrator, and the administrator user name and password were being used for authentification.

All of a sudden it has stopped working? any ideas why? the only thing i was thinking about is if I have had VNC running on this machine in the past could there be some sort of conflict going on in the background?

Network connection is fine.
 

vampyre

Registered
try turning off VNC and disable the "allow vnc to adminisiter using password" in the clients sharing prefs.

is the RDC client up tp date (currently 2.2)?

failing that delete the client from your master or list and re-add them and see what happens.
 

edadams

Registered
Hi

I usually find ARD sometimes does not work as it should and requires a small helping hand to work.
I generally run this command in terminal when ARD misbehaves (you will need to ssh to server to do this)-

cd /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources

sudo ./kickstart -activate -configure -access -on -users username -privs -all -restart -agent
Replace 'username' in the second line with your ARD approved user

Can you connect with the VNC client?
 
Top