Project Builder Executable


I've been working on a Unix program in Project Builder, and everything has, for the most part, worked fine. However, I cannot figure out how to tell the executable to run files from the same directory. Instead, it keeps looking in my user home folder as the active directory. How can I change this without using absolute paths? I just want it to open files that share the same directory as the executable.
After a little experimentation, it had to do with how the Unix shell was starting. I just had to go into the Terminal preferences and tell it to log in with the command 'bin/tcsh' instead of logging into 'usr/bin/login,' and the executable would run in its native folder.