Puma PHP Install -how-???

vic

RRRrrrRRRrrrRRrrr
How do u get php to work under os x.1?
Cant's comfigure the dame as osx 10.1.4!
 

vic

RRRrrrRRRrrrRRrrr
i meant, 10.0.4 as int the current update, and i have buid 5G64 as in the 10.1 and i can't get php configured under the same instructions as 10.0.4 from stepwise, which has always worked until this puma upgrade.
 

vic

RRRrrrRRRrrrRRrrr
i installed the dev tools fot 10.1 it seems tha ti was able to onfigure paghe and php, but! when i checked my page in explorer i got this:

Can someone help! i need php to work and 10.1 update screwed my instaltion, and afterr i've done aclean install, i can't get it to work with the same exaples as i go it to work before!
 

Attachments

Straylight23

Registered
Hi,

this looks more like an Internet Explorer-problem. Did you check other browsers? For me the 10.1 update worked just fine (with php).

cu:Stray
 

avalenz

Registered
Actually, to me it looks like you possibly did not configure Apache to recognize and process .php files. go to your httpd.conf file and make sure you have UNcommented lines like:

AddType application/x-httpd-php .php3
AddType application/x-httpd-php-source .phps

and

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

Good luck.

-Ali
 

vic

RRRrrrRRRrrrRRrrr
i did that , i told you i already got it working in 10.0.4, but not in 10.1 and using both omniweb and explorer will make the file start downloading if it has a php extention! if you ACTUALLY have 10.1 installled WITH php, and it WORKS, then help me out if not stay out of this as it's no help to anybody.
 

Straylight23

Registered
Hey vic,

why are you so mad? :confused: Telling people to stay out of this won't help a single bit.
Now again (me risking making you even more mad), please have another close look at your httpd.conf. Maybe your 10.1 installation changed this file and you missed something?
How about:

AddType application/x-httpd-php .php

How about posting yout httpd.conf, it might help.

cu:Stray
 

vic

RRRrrrRRRrrrRRrrr
# AddType allows you to tweak mime.types without actually editing it, or to
# make certain files to be certain types.
#
# For example, the PHP 3.x module (not part of the Apache distribution - see
# http://www.php.net) will typically use:
#
AddType application/x-httpd-php3 .php3
AddType application/x-httpd-php3-source .phps
#
# And for PHP 4.x, use:
#
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

AddType application/x-tar .tgz


it did not change, and that is not really my concern since i tried rebuilding php exactly like i did in 10.0 .4 but with no luck. and i don't want to get you guis mad, but what's the point of someone trying to help someone when that person can't help them from the start. there is no point. so i have a simple question, and don't get mad, just answer it: do you have 10.1 running with php working?

and can u install print driver? did your preview apps export fuction get fucked up like mine? does the f12 key eject media in classic?
 

Straylight23

Registered
Hi,

Originally posted by vic
so i have a simple question, and don't get mad, just answer it: do you have 10.1 running with php working?
yes. It did from the beginning. No tweaking. Everything fine.
If you like, here is my httpd.conf:
 

Attachments

Straylight23

Registered
Hi,

the "Virtual Server"-Directive within this httpd.conf is invalid. Hence the server is not working properly. Without it it works fine (uncomment "Listen" and "Virtual Server"). You can see it running here:
 

00101001

Registered
Ok, this is what got it working for me...
-open up your httpd.conf file
-line 239 ... it should say LoadModule php4_module
uncomment it.

-lines 281, AddModule mod_php4.c
uncomment it too.

838 839 843 and 844 all must be uncommented as well
(you can just do a search for "php" and uncomment whatever is needed)

that should get php working

BUT, if you want it to pop up as a default page, check out line 441
it is the DirectoryIndex line, make it so that after index.html, it says index.php

so: it should be:
<IfModule mod_dir.c>
DirectoryIndex index.html index.php
</IfModule>

that is how i got it working and make sure to restart apache after making these changes, or else nothing will happen

--LB
 

Straylight23

Registered
Hi vic,

Thanks for the link. Stepwise is always a good thing to look for MacOSX-ressources.
It's good to here that you've solved your problem :)

cu:Stray
 
Top