trying to run the example for pygtk and get a message about:
No fonts found; ....
More information can be found in the fontconfig(3) manual page and on

tried the sudo fc-cache trick and still no dice.
I copied over the from the installation disk and am running in the xterm shell. Am I on the wrong $PATH or something??

You need to install fontconfig as well, since that doesn't come with the default X11. You might find it easier to just install pyGTK via fink. It handles all the dependencies for you, and keeps you sane for longer :)
i guess i will go over to the fink side and try it out. darwinport seemed fine for most things i have been trying to accomplish
actually, i did install fontconfig from darwinports... Is there something about my X11 paths that is not right? I don't have any LD_LIBRARY_PATH directories

i am also trying pyqt and have rebuilt it under 10.4 Things are a bit weird, but i am tracking those issues down.
So what are you using now? Darwinports or fink? You shouldn't mix and match these two, unless you are prepared to be messing about with paths and such.

On OS X, you the path to libraries is DYLD_LIBRARY_PATH. You could try setting that.