Quake 3 for OS X

mr.sector

Registered
From www.xlr8yourmac.com :

ID's Quake3Arena page lists a 1.29f Beta version release including one for OS X. Changes are noted as:

The list of changes in this release is just massive!
In a nutshell...
« New pro maps
« New network code
« New auto-update system
« New rail, rocket, plasma, and lightning gun effects
« New cheating counter measures

This release will update any previous installation of Quake III Arena

The Q3 page notes that "A Mac "Classic" release is not available at this time, but we will have an official release when this release moves out of a beta state."

get it on www.quake3arena.com
 

jdog

Not a Moderator
You beat me to it mr.sector. Quake3 runs pretty well on my TiBook, though the 8mb Ati card leaves me wanting more...

-jdog
 

Titanium

Registered
...on the 8MB ATI card lacking to pack a mighty punch. I'm running it on my P/B and am in fact somewhat disappointed. It only runs at a rather low-res (800x640) and you can FORGET about 32bit textures. all other details need to be "screwed down", too, unless you wanna play in a completely "hacky" environment. and we all know what happens in M/P with hacky games.
Is there actually ANY way to "upgrade" the graphic-card in the P/B? its kind of a pain. i mean if you have a big clumsy desktop, you just put a big clumsy card in it that turns big-clumsiness into quick-smoothness. with my smooth looking P/B i seem to be pinned down to the ground, laying on my back like a bug whirling my arms and legs and desperately squeeking "pweese, oh pweese more graphic power??? pohleeeeze?!?!!"
kinda pathetic isnt it? i know i know...that's how i feel, too when i steer my character through the mazes of the levels in M/P maps with big pixel blotches on my screen. UGH.
so...bottom line: is there any solution to this sadness?
lemmie know what you know...
The King of Irons,
Titanium
 

Titanium

Registered
did you follow the "installing instructions"??
maybe you should just completely erase it and then re-install it.
which works like this:
you un-pack the "download"...and into that directory you COPY a part of the cd, which i dont remember right the name right now, but it's in the "readme" file of the macosx-patch-download. do NOT install it using the Q3 installer, which will startup classic. maybe that's the mistake?
good luck brother, but i hope once you got it running you wont be as disappointed as i was and still am.
*shrugs*
The King Of Iron,
Titanium
 

Fahrvergnuugen

I am the law!
Q3A will crash if you did not copy the pak0.pak file off of the cd or out of your old quake directory. I simply copied the Q3A application into my original Q3A folder, and then replaced the files in the baseq3 folder that came in the update. Piece of cake.

Frame rates are higher in OSX on my G4 than they are in 9...which is surprising considering all of the feed back I have heard about how much slower everything is in X.

Not a single complaint here!
 

AxsDeny

Registered
The problem is, I have to unplug the monitor and then restart the machine. Hell knows why, but I do.

This is crap. They gotta fix that in a release...
 

Crunchy in milk

Journey Agent
Bah the mouse control is still nonexistant on osx q3 :mad: nothing at all like the way it behaves in os9 q3. Until whoever is responsible fixes the way the mouse behaves in osx q3 its not worth playing :(

 

jdog

Not a Moderator
Is your mouse behaving badly? Maybe a time-out will help? What exactly is your mouse doing?

-jdog
 

AxsDeny

Registered
which mouse are yo uusing? I'm using the Kensington 2 button scroll mouse... but I've yet to get the damn app to run so i can't comment on the performance.
 

Crunchy in milk

Journey Agent
Originally posted by jdog
Is your mouse behaving badly? Maybe a time-out will help? What exactly is your mouse doing?

-jdog
In os9 the mouse behaves brilliantly, the reaction is fine. I have never edited anything other than the 'sensitivity' setting within quake3.

When loading quake3 for osX you only have to reach the menu screen to see how much the mouse movement has changed. The cursor seems to move of its own accord, when moving it continues to trail after the mouse has stopped, it is like the monitor is a skating rink and the cursor slides around clumsily. For some reason when going into the 'settings' menu of quake3 its back to tight response, but in game and any other menu, I'm back on the rink.

I can't explain why its like this, I only know that Im one among many who have the same problem, and it doesnt appear to be just with my mouse type (apple pro mouse). Its an often mentioned bug in the macintosh q3 discussion forum on www.quake3world.com/forums

I truly hope to see the solution to this soon, either by an osX update or another release by ID. Maybe the altivec version even.
 

Anton

Pixelated Artist
curious....
I have a puzzle to solve.

I'm quite certain that I installed it correctly... doesn't exactly take a rocket scientest anyway... but this is the first time I've seen a complete system lockup under X for me. No kernal panic, no error code... just solid freeze. consistantly.

It's possible that there may be some kind of incompatibility with my flat panel. Hell, I found a bug in Photoshop with the new display under X. But that will be a new thread... ok.. back to Quake (sorry, I digress easily).

When I get a chance I'll switch out my monitor and try this again.
And I'll let everyone know the results of my efforts.

Is there anyone else with one of the new 17" studio displays?
If so, any problems under X?
 

BriMister

Registered
I have the new public release of Q3 1.29f and it is sllooow

I'm on a G4 400 with a 32MB Radeon and 608MB of RAM.

while I don't play any quake, I do play Urban Terror (a Q3 mod) and Frame Rates specifically have dropped to terrible levels. Went from an average of 40-60FPS in OS 9 to 15-35 FPS in OSX. This sucks. 15 FPS is unplayable. Anyone know what the problem is? Is it in the Q3 code? Or is it in OS X?

--Bri
 

Gnarled

Registered
The first issue is I had a very weird install for Q3 129 for osx. I installed the classic version and it came with a .app program inside it, later when i went into OSX i tried the .app and a screen said demo, then it launched the full normal version of quake 3 version 129. So no problem there, just weird.

My other problem has nothing to do with OSX. I have been trying to get Q3 Urban Terror for some time now, but i download the installer and it gives me an error that the installer is damaged and it has expired. Then it quits, but it did make a q3ut2 directory in my q3 dir. but only put one file in it... q3config.cfg
Does anybody know where i can get a good q3 ut installer. I have already tried both on www.urbanterror.net.
 

iMan

?¿?
I installed Quake 3 just as it said in the read me file. But when i sart up it gives me an error saying that it can't start openGL and that I don't have a graphic card suported with openGL. I have a Powerbook Lombard G3 and that one have a graphic card as standard. Have anyone els had this problem?? Does anyone know what to do???

I did a test with instaling quake 3 for classic and run it under classic but I just got a error sayng that it could't run openGL...
 

Lolo

Registered
Hi,
Anton have you tried to force Quake3 to quit?

I noticed that when Q3 is running, the normal shortcut to launch the task manager is not working, but you can press ENTER, it forces Q3 to crash and you are back to the finder.

On my machine, Quake3 is very fast (enough to play anyway) and very stable. I am playing on the small network I did in my flat against a PC (Athlon 500MHz, Riva TNT2) and the Mac is a little bit slower but the image quality is amazing compared to the one on the PC (both have trinitron screens: Nokia for the pc and Iyama for my Mac).

 
Top