Quartz 2d Postscript to Pdf Conversion Hangs

bardia

Registered
Hello,

I have a problem with the Mac OS X internal PostScript to PDF conversion. I believe this is done by the 2D part of the Quartz engine of which of course I know almost nothing. Any application that attempts showing a PostScript file, including Safari, Preview, and Mail, hangs with the beach-ball rotating for ever and so does the command line utility "pstopdf" (no beach-ball there).

When I first bought my iBook a couple of months ago, it didn't have the problem. I installed a few things, among which I suspect teTeX and its PostScript fonts the most, and at some point the problem started. My friend has had a PowerBook for a couple of years and he has had the same problem: from some point on, no PostScript to PDF conversion succeeded.

I can of course use Ghostscript for the conversion which works perfectly fine but when I receive a PostScript file in the mail, the Mail application tries to view it and then I have to "force quit". I am not interested in paying for the iconizer add-on that prevents Mail from showing the attachments. After all, this is a deep-down OS functionality that is out of order and I want a true fix for it, not just a bypassing hack.

Any help will be appreciated,

-- bardia
 

MisterMe

Registered
I can assure you that teTeX is not your problem if you installed it correctly. I keep my installation of teTeX up to date on a nearly daily basis. It has never caused me one nanasecond of trouble. I have never read a report of any other user having even a picosecond of trouble with teTeX. I hope that you know that MacOS X comes with GhostScript installed as part of the CUPS printing engine. You should not install a third party version and are warned not to do so. Because Apple includes GhostScript as part of the standard OS, you cannot expect any version available for download to be compatible with MacOS X 10.3 or 10.4.
 

bardia

Registered
I actually figured a way to fix the problem. The trouble came from having some pfb fonts in my /Library/Fonts. These were the file names:

ucrb8a.pfb, ucrro8a.pfb, uhvr8a.pfb, utmb8a.pfb, utmri8a.pfb, ucrbo8a.pfb, uhvb8a.pfb, uhvro8a.pfb, utmbi8a.pfb, uzdr.pfb, ucrr8a.pfb, uhvbo8a.pfb, usyr.pfb, utmr8a.pfb

I removed them and everything came back to normal. I still have no idea which application installed the fonts there. I did install a version of Ghostscript with my TeX installation and it works perfectly fine. Anyway, this is apparently a bug! The PostScript distiller is not supposed to fall apart if it finds unsupported font files in the fonts folder.
 

MisterMe

Registered
Corrupt fonts will bring a Mac to its knees faster than just about anything else. I strongly recommend that you use Gerben Wierda's i-Installer utility to install and maintain teTeX on your system.
 

fgoodman

Registered
I have exactly the same problem, and have had the problem through many versions of OS X. I do not have any .pfb fonts in my /Library/Fonts or ~/Library/Fonts folders.

I tried running pstopdf from the command line; it checks fonts and list the fonts as it checks. It hangs up on a certain tex font PazoMath-xxx. I tried
removing any instance of pazomath fonts, or fplmxx.pfb fonts. This didn't help. It seems I can't find the offending font.

Does OS X keep some font list somewhere that needs to be manually updated?

Any suggestions are very welcome.
 

fgoodman

Registered
Another solution which worked for me was to clean the system font caches.
I used Linotype FontExplorer to do that. You can also use Yasu.

So summary of the discussion: If you have ps -> pdf conversion hanging up

1. Run pstopdf from the command line and see if it hangs up checking fonts.
2. Remove suspicious fonts.
3. Clean your font caches.
4. If all else fails, you could replace Apple's pstopdf with a script calling
ghostscript ps2pdf.
 
Top