QuickTime 7.0.2 - warning & question

Mikuro

Crotchety UI Nitpicker
The latest QuickTime update seemed small and innocent enough, so I went ahead and installed it. Unfortunately, it is no longer compatible with Divx, which is a real deal-breaker for me. So if anyone else relies on Divx, be warned.

Note that the Divx 6 beta ( http://labs.divx.com/ ) does seem to work with QT 7.0.2, but performance is significantly worse than Divx 5 with QT 7.0.1. I'm not sure if that's due to bad compatibility with 7.0.2 or just because the Divx 6 beta is not yet as optimized as Divx 5.

Now my question: How should I go about downgrading back to QuickTime 7.0.1? I'm not sure where to begin.
 

fryke

Moderator
Staff member
Mod
Reinstall Tiger would be it, I guess. Can't really downgrade such updates, I'm afraid. But I'm sure if it's really a problem, some DivX update will solve it. For the time being, why not use VLC to play DivX content.
 

Mikuro

Crotchety UI Nitpicker
fryke said:
Reinstall Tiger would be it, I guess. Can't really downgrade such updates, I'm afraid. But I'm sure if it's really a problem, some DivX update will solve it. For the time being, why not use VLC to play DivX content.
Well, Divx still hasn't solved the pre-existing issues with Tiger even after all this time. And Divx 6 has been out for Windows for some time. So I'm not gonna hold my breath. :(

As for VLC, it's fine for straight playback, but it's no substitute for QuickTime, I'm afraid. I need editing, decent scrubbing, adjustable speed, etc, etc. The good news is that I've started using non-QT tools for my encoding anyway, so that won't be a huge problem.

I'm going to see if I can pull off some tricks with Pacifist and my Tiger DVD. There's gotta be some way...

Some "compatibility" update! ::ha::
 

Mikuro

Crotchety UI Nitpicker
Hmm. I have no idea what the difference between our setups is. But then again, Divx's QT7 compatibility has always been a your-mileage-may-vary kind of deal. Many people reported many different problems even with QT 7.0.1 that I never had (like the "two Help menus" bug and the "Classic won's start" bug).

But I don't care anymore, because with a little hacking, I came to a solution! I now rely on the Xvid codec for my video decoding, since it's faster than Divx 6 (about the same speed as Divx 5). The problem there is that only Divx can properly decode the audio in most AVIs, and when Divx 6 is installed, it takes over all the video decoding, too.

But I found a way around that problem! You have to open up "Divx Fusion Decoder.component" (control-click, and select "show package contents"), and remove some of its guts. Specifically, the file "DivX 6 Decoder.rsrc", in the Contents/Resources folder. Trash it, then quit+reload QuickTime Player. Without that file, Divx will handle the audio decoding, but Xvid will do the video. I'm getting performance comparable to what I had before now, so I'm a happy camper. :)
 

gordonplant

Registered
After upgrading to 7.0.2 a bunch of MPEG4 files that worked fine under 7.0.1 no longer have usable audio when played in QT player. The audio plays for a second or two and dissappears.

These files can still be played back using VLC 0.82 so it looks like a QT 7.0.2 playback problem.
 

Mikuro

Crotchety UI Nitpicker
Gordon, what codecs do you have installed? Your problem sounds similar to one I experienced when I was using Xvid alone (as I said, now I'm using Xvid + a hacked Divx 6, and everything's running perfectly). That was for AVIs, though. Are you referring to mp4 files?
 

gordonplant

Registered
Mikuro,

Thanks for your reposnse.

>Gordon, what codecs do you have installed?

As far as I know I only have the codecs that shiped with the OS, Pro apps and Eye TV.

The files I'm having trouble with are exported from Eye TV using the MPEG4 option and they have a .avi suffix.

QT player properties shows this:
MPEG4 Decompressor (libavcodec), 768 x 576, Millions
MPEG, Stereo, 48.000 kHz

Do you think the problem is libavcodec?

Gordon
 

MisterMe

Registered
It sounds to me as though libavcodec is exporting DivX rather than standard MPEG4. If you install the latest DivX Fusion beta codec, things will probably work fine for you.
 

PurfxDesigns

Registered
Hey everyone (new to the site). I've been reading up on this stuff all day, and I'm seeing a recurring theme. There are folks with trouble in any number of applications. I'm having it in DPS Adtracker, and getting a invalid kern...
I did the updates this morning and been messy ever since.

I bet that if you can find a way to go from QT 7.0.2 back to 7.0.1 (or earlier) your software will return to normal.

I just can't find the way to do that without having to reinstall the OS.

Hope someone can help.
 

gordonplant

Registered
I've talked to tech support at Eye TV and they tell me that they believe the problem is a bug in quicktime 7.0.2. They have reported the bug (of course) so hopefully it's just a case of waiting for 7.0.3....
 

Mikuro

Crotchety UI Nitpicker
Whoah, look what I just found! An Apple-supplied downgrader: http://www.apple.com/support/downloads/quicktime701reinstallerforquicktime702.html
From the page I just linked... said:
About QuickTime 7.0.1 Reinstaller

The QuickTime 7.0.1 Reinstaller will remove QuickTime 7.0.2 and restore your system to QuickTime 7.0.1.

Note: In order to restore your QuickTime version to QuickTime 6.5.2 from QuickTime 7.0.2:

1. Apply QuickTime 7.0.1 Reinstaller (from this page)
2. Then apply QuickTime 6.5.2 Reinstaller for QuickTime 7.0.1.
I haven't used it myself (since I got 7.0.2 working to my liking), so I can't personally vouch for it, but it seems like Apple answered our cries.
 

Mikuro

Crotchety UI Nitpicker
Hey, it looks like the Divx folks have fixed the problems I was having with their new Divx 6 beta 3. Available at http://labs.divx.com/. No hackery required.

EDIT: Oops, I spoke too soon. The new beta does still have some issues. Performance is good, but there's a problem with white flickering sometimes. Fortunately, the hack I described for the old version still works. So Xvid + Hacked Divx 6 is the way to go for me.
 
Top