Rather Annoying Garageband Issue


I'm hoping someone might be able to help me with a persistant and rather annoying problem I'm having with Garageband. I've used Garageband since it first came out and my version is the most up to date (i.e. if I do "check for updates", it says I'm on the most recent available). However, I haven't run it in a while. Now, when I launch the application, it takes a little while to try to open and then displays an error that reads :"Timeout or Timer Not Running". I click ok and it redisplays. This repeats for a number of times and then finally the application opens but displays "Mac OS X Midi Services Not Available". If I then try to do anything it brings back the original "Timeout or Timer Not Running" error. I've done some searching on here and on the net but I can't find much info about this problem. If anyone has any help for me that would be great:

My specifics:

G4 Dual 1.25ghz MDD with 1gb ram and two internal 25gb hard drives.
OS X 10.3.9
Repair permissions run before an after any update (and I have run it in debugging this issue as well)
iLife05 patched to most recent versions
LaCie external 200gb firewire drive on the Firewire 800 bus
LaCie external 80bfg firewire drive on the main firewire bus (neither of these drives are new or have been the source of any issues for me in the past and they have both worked well with GB in the past).
iSight firewire cam on the main bus
M-Audio Firewire 410 audio interface on the main firewire bus with firmware patched to the most recent available
M-Audio Midi keyboard connected via USB (always worked great with GB in the past)
Standard Apple USB keyboard
Logitech infrared USB Wheel Mouse (not new and has always worked well)