Rdc On Os X 10.2.8



I'm currently having issues trying to support one of our G5's running OS X 10.2.8.

Initially we were having issues with applications in the classic environment so I decided to build a clean image and exclude classic.

With the exclusion of classic all seems to be running smoothly with the exception of one thing. We still need access to some applications that are only available on OS 9. To get around this we have installed these apps onto a Windows (w2k sp4) box (as our windows users also use these apps) and told our Mac users to use RDC to connect.

All connects fine and dandy and our Macs are able to work away as normal. All problems solved right? No. I'm having issues with the Macs disconnecting from the RDC session. I've checked session idle limits on the terminal server Box that they connect to and all seems fine.

On mac in particular gets the following error:
The client could not connect to the remote computer. The connection was ended because of a network error. Please try connecting to the remote computer again.

He is then able to reconnect straight away. Our user advised that this could happen anywhere from 10mins idle to 30mins.

Looking online I'm yet to track down this error and any possible causes. I've tried re patching his network connection to another switch and checked cables etc (just in case). Looking at Terminal server manager on the windows box I haven’t seen any possible cause that sticks out.

Any help on this would be great as I'm starting to pull my hair out over this one, not to mention my unhappy user.