Reading Burned Dvd's (superdrive Dvr-106d)


Hey Guy's

I have tried to resolve this issue myself, but have given up and must rely on the experts.

I am Running OS X 10.4.2 Build 8C46
on a Dual 2 GHz PowerPC G5

I have recently upgraded the drives firmware to 1.08 using the FlashIT program. I tried 1.07 to allow the drive to burn faster. I think that's when the problem started. it might have existed before but have never ran into it.

Using the 1.07 (Hacked) Firmware discs that were in the drive too long would not eject and cause me to have to reboot!!! Also it would not read Burned DVD's. I then found the 1.08 (Official) firmware upgrade and the idle issue went away.

Now everything works great except I still cannot read burned DVD's. Commercial DVD's work fine. Cd's Work fine too... I input the disc and the drive makes a little clicking sound, then another, then just sits there for awhile (30 sec) and ejects the disc.

I just reset my NVram and that did not do the trick. Just wondering if there is any thing else I can try, before I revert back to the 1.06 (Official) firmware which I don't think will help. I have seen many posts kind of addressing this issue but no fixes that have worked. Even from people that have not updated there Firmware.

Thanks for your help!!

P.S. here's some more info from System Profiler:


Firmware Revision: 1.08
Interconnect: ATAPI
Burn Support: Yes (Apple Shipped/Supported)
Cache: 2000 KB
Reads DVD: Yes
CD-Write: -R, -RW
DVD-Write: -R, -RW, +R, +RW
Burn Underrun Protection CD: Yes
Burn Underrun Protection DVD: Yes
Write Strategies: CD-TAO, CD-SAO, CD-Raw, DVD-DAO
Media: No



I have this same problem with the PowerMac G5 I have, it just won't read some CD's, and I don't know why, so I can't use those CD's. Just something about the brand or something.