Really odd problem

chrisjasper

Registered
This one has me really stumped.
I have an iBook G4, running Tiger v10.4.1.
Connected to the network at work through a cable or to my wireless network at home it runs beautifully, but as soon as its in a location without network all applications refuse to launch. They will bounce in the dock for a minute then stop. Ocassionally I can get one app to launch so I usually try terminal first and attempt to run top to see if anything is blocking up the cpu, but attempting to run top also fails.

I initially thought it was Virex 7.6 as it reported 96%cpu in single user mode, but after removing this I still have the same problem.

Any ideas anyone?
 

Damrod

Registered
Have you tried a fresh user account? That could show if it's bacause of some corrupt prefs or something.

Maybe it has something to do with the network settings. Do you have net-volumes that mount automatically when you're in one of the mentioned networks? Maybe the machine gets somewhat stuck while searching for those volumes not present.

Right now, those are the two first ideas that come to my mind.
 

chrisjasper

Registered
No, fraid not. No network volumes mounted at startup and fresh new admin user or normal user accounts have the same problem.
 

Damrod

Registered
How is your network device (Ethernet, AirPort) configured? Have you tried an environment under Network where the unused Network devices are disabled?

Do you switch from DHCP to static IP when not in an network? If you don't, I would try that.
 

chrisjasper

Registered
I dont use DHCP anyway as I need to bypass the gateways I set up for some functions, but I havent tried a disabled network device location, I'll give it a shot.
 

chrisjasper

Registered
That seems worse, now the finder doesnt launch I just get the blue desktop background.
It actually seems to be getting progressively worse.
Im almost getting to the archive and fresh system install stage.
 

chrisjasper

Registered
Oh hell, now that I set the network location to devices disabled, the machine wont launch login or finder even with a network cable attached, anyone know how to enable a different location form the command line?
 

chrisjasper

Registered
Well, an archive and install of Tiger seems to have removed the problem. Lets hope it doesnt come back.

Thanks anyway damrod
 

Damrod

Registered
That would have been one of the next thing I would have suggested :)
 
Top