Remote-X not working (MacOS as Client)

Tom.bEE

Registered
Hi there,

A few weeks ago I switched my Desktop OS from Linux to MacOS X (10.4.2). I used Linux (Mandrake, Slakware, Debian, Gentoo etc.) for about 2.5yrs as my preferred Desktop OS.

Now that I've used OS X for a couple of weeks, I really really need to run some X11-programs I am used to (ethereal, NmapFE and maybe Kate).

I tried Fink to have them run on my Mac, but after having some trouble I decided to run all Linux-Apps remotely on my Debian-Server-Box. I think this is a better way, as these apps have been tested and mostly developed for Linux. So no hassle with bad ports and this kind of crap.

After installing X11 (usual Apple-Release) on my Mac, I did a "xhost +" (yes, I do have a firewall and no untrusted computers around ;) ), logged into my Debian-Box and could instantly run any X-Application I wished to.

That was easy, I thought. Actually the easy configuration was it, that let me switch to MacOS.

But unfortunately after this first test, my apps are unable to find my DISPLAY again. Now I'm not able to run any programs using remote X anymore ;( (I do not know why, I didn't change anything. It just didn't work anymore)

I always do the xhost-stuff and I also tried to forward X with ssh. I did turn on forwarding in sshd_config and ssh_config on both sides (each).

No change. $DISPLAY is set in xterm running on the Mac. But when I ssh into my Debian-Box using the -X option the DISPLAY-Variable gets lost.

I also tried to do it without ssh. No chance, no display.

I always get this:

ux-server:~# DISPLAY=192.168.10.22:0.0 ethereal

(ethereal:10099): Gtk-WARNING **: cannot open display:


I googled around the world for this, but all threads I found don't match my case. They all forgot to turn forwarding on or didn't give access using xhost.

I'm really stuck now.

One thing to mention: On Linux the X-Server uses ports 6000+ for remote-x. On my Mac no port 6000 or above is used. Maybe this is the reason why "DISPLAY=192.168.10.22:0.0 ethereal" couldn't connect?

Please help! If I can use fully Remote-X on my Mac I will totally be happy with this gorges thing of computer.

Thank you very much,
Thomas
 

irobot2005

Registered
Tom.bEE said:
Hi there,

A few weeks ago I switched my Desktop OS from Linux to MacOS X (10.4.2). I used Linux (Mandrake, Slakware, Debian, Gentoo etc.) for about 2.5yrs as my preferred Desktop OS.

Now that I've used OS X for a couple of weeks, I really really need to run some X11-programs I am used to (ethereal, NmapFE and maybe Kate).

I tried Fink to have them run on my Mac, but after having some trouble I decided to run all Linux-Apps remotely on my Debian-Server-Box. I think this is a better way, as these apps have been tested and mostly developed for Linux. So no hassle with bad ports and this kind of crap.

After installing X11 (usual Apple-Release) on my Mac, I did a "xhost +" (yes, I do have a firewall and no untrusted computers around ;) ), logged into my Debian-Box and could instantly run any X-Application I wished to.

That was easy, I thought. Actually the easy configuration was it, that let me switch to MacOS.

But unfortunately after this first test, my apps are unable to find my DISPLAY again. Now I'm not able to run any programs using remote X anymore ;( (I do not know why, I didn't change anything. It just didn't work anymore)

I always do the xhost-stuff and I also tried to forward X with ssh. I did turn on forwarding in sshd_config and ssh_config on both sides (each).

No change. $DISPLAY is set in xterm running on the Mac. But when I ssh into my Debian-Box using the -X option the DISPLAY-Variable gets lost.

I also tried to do it without ssh. No chance, no display.

I always get this:

ux-server:~# DISPLAY=192.168.10.22:0.0 ethereal

(ethereal:10099): Gtk-WARNING **: cannot open display:


I googled around the world for this, but all threads I found don't match my case. They all forgot to turn forwarding on or didn't give access using xhost.

I'm really stuck now.

One thing to mention: On Linux the X-Server uses ports 6000+ for remote-x. On my Mac no port 6000 or above is used. Maybe this is the reason why "DISPLAY=192.168.10.22:0.0 ethereal" couldn't connect?

Please help! If I can use fully Remote-X on my Mac I will totally be happy with this gorges thing of computer.

Thank you very much,
Thomas
X stopped working correctly when I upgraded to Tiger, the primary culprit seems to be a new version of ssh (see ssh man page on -X and -Y flags). I did two things to get things to work again. Added trusted X11 forwarding, so I now have:

ForwardX11 yes
ForwardX11Trusted yes

in /etc/ssh_config. I also nuked my X11 preference file, so if I type:

defaults read com.apple.x11

at the prompt, I only see:

{
"NSWindow Frame x11_apps" = "527 546 486 332 0 0 1440 878 ";
"done_xinit_check" = 1;
}
 

phinsman

Registered
Thomas, you may have already covered this, but just to be sure, make sure the X11 app is actually running on your Mac while you're trying this stuff. That's what happened to me...I had everything up and running one day, then the next day, nothing was working, even though I was 90% sure I had it all right. As it turned out, I just didn't have X11 running the second time. I didn't realize I needed to start it myself somehow; I'm just more used to GNU/Linux systems.

Dale
 

sourcehound

Registered
phinsman said:
Thomas, you may have already covered this, but just to be sure, make sure the X11 app is actually running on your Mac while you're trying this stuff. That's what happened to me...I had everything up and running one day, then the next day, nothing was working, even though I was 90% sure I had it all right. As it turned out, I just didn't have X11 running the second time. I didn't realize I needed to start it myself somehow; I'm just more used to GNU/Linux systems.

Dale
use SSH -X from Xterm after launching X11 on your OS X system to connect to your remote system then you're golden....

Sourcehound, author of Mac HelpMate http://www.macworkshops.com/machelpmate

ACSA, ACTC, MCP, APP, Mac IT Trainner and MacTech Columnist
http://www.macworkshops.com
 

slocklin

Registered
all you have to do is use ssh -Y
If X is set up right (and it's hard to screw up on a mac; flip the button that says "allow forwarding" and you're done); you are finished.

If you turn this on at the config level, you're doing promiscuous xauth, which is a security issue.
 
Top