remote X session

dsidote

Registered
I am trying to use a remote X windows session on my mac without much success. I have a program installed on my linux computer which is connected to our LAN. I can setenv DISPLAY my.ip.number:0.0 and then telnet to the linux computer and run the program using my SGI. I have installed XF4.1 on my mac but when I try this I get the following error:

Last login: Fri Jun 29 09:21:21 from pismo.icmb.utexas.edu
[dsidote@hermione dsidote]$ sparky
Xlib: connection to "146.6.133.154:0.0" refused by server
Xlib: Client is not authorized to connect to Server
Tk_Init error: couldn't connect to display "146.6.133.154:0.0"
Traceback (innermost last):
File "<string>", line 1, in ?
File "/home/goddard/sparky/install/python/sparky/__init__.py", line 44, in sta
rt_session
File "/home/goddard/sparky/install/python/sparky/tkutil.py", line 919, in init
ialize_tk
File "/usr/local/sparky/python/lib-tk/Tkinter.py", line 886, in __init__
self.tk = _tkinter.create(screenName, baseName, className)
TclError: couldn't connect to display "146.6.133.154:0.0"
[dsidote@hermione dsidote]$

Can someone help me out with this one?

thanks,

dave
 

sveijk

Registered
Sounds like an access control issue. Did you "xhost hermione" before logging in? That should do the trick.
 

strobe

Puny Member
You can also use ssh for piping a remote X11 session. This not only has the advantage of being a secure encrypted authenticated connection, but you can also compress the stream which I have found useful.
 

sveijk

Registered
Originally posted by strobe
You can also use ssh for piping a remote X11 session. This not only has the advantage of being a secure encrypted authenticated connection, but you can also compress the stream which I have found useful.
Most ssh setups, including the default compile of the proprietary version, not only automatically port forward X, they take care of access control and set your display variable. This means you can just ssh in to the remote host and start an X client (application). No need to type anything else. Unfortunately this does not seem to work in the OSX OpenSSH install. It automatically does the X port forwarding, but you must manually set the variable and access control (at least on my setup). I haven't looked into fixing it yet.

Strobe is correct. You should use ssh. In fact, you should turn the Telnet and FTP daemons off and only use ssh/scp/sftp.
 

dsidote

Registered
I am going to try to get that setup now that I have the telnet setup working. Thanks for all the help.

dave
 

kilowatt

mach-o mach-o man
I can't get remote X apps to launch via ssh. I've tried launching programs off the mac on my linux (and sparc) boxes, it doesn't work. And vice versa doesn't work either (which is what I really want - launching the linux apps on my mac via ssh).

Telnet works fine, and even my scroll mouse on the mac will scroll through netscape 6 (intel/redhat).


(and yes, incomming telnet connections are refused, but anyone who has ever used a packet sniffer knows all the garbage you'd have to go through to figure out what someone is doing over a remote X connection...)

 

sveijk

Registered
Originally posted by kilowatt
I can't get remote X apps to launch via ssh. I've tried launching programs off the mac on my linux (and sparc) boxes, it doesn't work. And vice versa doesn't work either (which is what I really want - launching the linux apps on my mac via ssh).
Can you desribe the failure mode? Are there any error messages? Have you checked your config files to make sure X forwarding is not disabled?


(and yes, incomming telnet connections are refused, but anyone who has ever used a packet sniffer knows all the garbage you'd have to go through to figure out what someone is doing over a remote X connection...)
It isn't so much the X sesion data I care about. I just don't like passing clear text passwords. Although, on a switched network, there isn't much danger there either. FTP OTOH, is just a security nightmare.
 

Zim

Registered
I was about to start a thread on this ;-)

Ok, I am trying to display windows from my Mac onto my system at work.

I found that X forwarding was turned off (by default?) in /etc/sshd_config

X11Forwarding no

I have changed this to yes, rebooted, ssh'd in to my machine, set DSIPLAY to my work machine, set xhost+ on my work machine, and still I get "cannot open display"....

Any ideas?

Anyone have this working.

With 10.0.4 I also started getting errors with ssh when X11 forwarding is yes (with just trying to log in).

Cheers,
Mike
 
Top