Reset File Share Service


I think I srewed up my file share service.
I tested with opensource samba beause of connecting with Linux.
Now nothing works :)

Can I somehow tell macOS to use factory default file sharing?

Thank you for your help


Rosie Moderator
Staff member
Go to System Preferences>Sharing. You should see a list of the folders you wanted to share along with the users you have given permission. Click once on the folder and you will see the users you have allowed to see that folder. Click on each user, then click on the minus to remove them from the list. Then click on the folder and click on the minus to remove the folder from the list.