Revert Firmware back to 4.1.8?


Hello all,
A while back, I had tried out an earlier build of OSX 10.1, and the disc burning feature worked great! (Sony CRX 120E/X Firewire drive).

I have since done the firmware upgrade to 4.1.9 (which was quickly pulled by Apple), and I have installed OSX 10.1. Now my Firewire drive isn't even showing up in the System Profiler, and I am extrememly frustrated. I've erased the partition a couple of times and reinstalled to the same result.

The drive shows up fine, and works, in OS 9.2.1. That's the odd thing. I'm wondering if the firmware update did something to break this for me. I have searched the web until my eyes hurt, looking for a way to revert Apple firmware versions. I'm willing to completely erase my drive. Arrrrgh! Help me!
Unfortunately, you're out of luck. Even if you're willing to reformat your hard drive, it won't make a difference to the firmware, and Apple's firmware update won't let you go "backwards in time." Maybe someone knows a hack to force the old firmware to load...
Apple's G4 firmware update came out today (4.2.8) Ran it - OSX 10.1 still refuses to recognize my Sony Firewire burner. I am NOT happy. And Sony says "We don't support OSX". Thanks guys.

And I guess Umax is never going to make drivers for their scanners for OSX. These 2 things render my computer almost useless for what I need.

So long OSX....back to ugly OS9 :-(