right click of command click is slow


whenever I right click on something be it a link or a file it takes ages (well a few seconds) for the options window to appear, does anybody else think its slow to pop up?

Running OSX 10.4.2
G5 dual 2ghz
2 gig ram


Not that it matters, but I have the same issue. I'm using OSX 10.4.2 on my Mac Mini 1.25 GHz with only 256 MB RAM installed, so I was blaming it on low memory / video memory. Guess not though?


Right clicks work great on my old machines.
It ought to be even faster on your g5 dually.

I occasionally use "Mac Sweeper 3.0 " to check and repair permissions,clean up the drive, etc.
Seems to keep these dinosaurs running nice and fast.
I use Panther ,though. Perhaps that feature is slower with Tiger.
With such advanced hardware, yours should still be faster.


Sorry to dig this old thread up again. I still havent been able to resolve the issue. I have tried the old repair permissions trick but it has not solved the problem...

Maybe its an OS/hardware configuration that I need to change. I will have a look and see if there is another update to Tiger available, but if anybody else has been having the same problems I would be interested in hearinf from them...

- Elliot.


Crotchety UI Nitpicker
Not sure if this is relevant, but command-click doesn't bring up a menu; that's control-click. If you're command-clicking, that might explain the delay, because it would only be bringing up the menu after a short delay, as it would with a regular click (the behavior is not a system-wide standard, but it works on the Dock and in some places in Safari). Just an idea.

I actually get this kind of delay, too. I control-click, hear my disk thrash for a second or two, and then the menu appears. I always attributed this to my paltrt 256MB of RAM, but if you have 2GB, that should hardly be a problem. :confused:


The Late: SuperMacMod
Mine (10.4.1) G4 is instant. Log into another user and see if you have the delay.


I created a new user and the problem persists. I think I will wait until the new release of tiger is available and maybe that does the trick. If not I think I will contact Apple...


Mac of the SubGenius! :-)
Like Mikuro said, make sure you are doing a CONTROL-click, not a COMMAND-click. The Command key and the mouse button don't do anything. All you would be experiencing is the same effect of just holding down the mouse button for a few seconds, which in turn would bring up the menu. If you CONTROL-click (without holding down the mouse button by the way, just hold down CTRL first and then click), then the menu should instantly come up.


sorry, yes I meant right click not a command click. I get confused when I have to use three different operating systems day in day out!