root access, telnet

lethe

Registered
OK, i know that this is a big security issue. but i want to enable the root access over telnet. i think i already did it on 10.0, but i can t remember. under linux, this option is in /etc/security, and in solaris it s in /etc/default/login. but in X.1 i find it nowhere.

let me worry about the security of my network, but does anyone know where they control what terminals can telnet to the system?

thanks
 

blb

`'
The file you're looking for is /etc/ttys, which has (among other lines) some that look like:

Code:
ttyp0   none                    network
In order to allow root to telnet in, you need to tag these lines (all through ttyqf) as secure:

Code:
ttyp0   none                    network secure
...
ttyqf   none                    network secure
 

jcpowers21

Registered
If you want to use ssh to login as root you have to edit one of the ssh config files in /etc and put that it is ok to login as root and then you are set their.

Justin
 

lethe

Registered
does the fact that there are only 16 pseudoterminal entries in /etc/ttys mean that i can only have 16 remote sessions simultaneously? i don t think i will need more, but i am used to having a lot more available than that. can i add entries to this files?

i don t know why, i havent looked at the sshd config files yet, but ssh session as root was enabled already, jcpowers.
 

blb

`'
That is a limitation (but there are 32, 16 ttyp and 16 ttyq); if you have all through ttyqf used, any future telnet's will say:

Code:
$ telnet localhost
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
telnetd: All network ports in use.
Connection closed by foreign host.
Not sure at this time what it takes to increase it; it isn't a simple matter of creating more /dev/tty entries and adding those to /etc/ttys. Probably a kernel change needed...
 

jcpowers21

Registered
You might want to go thru the netinfo tools, they may have something that can change the amount of term's you can have open across a network.

Justin
 
Top