root problem: setgroups operation not permitted



not sure what exactly i did, but now when i try to go to su access, i get a message "su: setgroups: operation not permitted"

i cant login as su anymore and dont have access to database files. i tried disabling the root user in netinfo manager, clearing the password and resetting, but nothing worked. thanks for the help.
From a Terminal window, does the command 'ls -l /usr/bin/su' show

-r-sr-xr-x 1 root wheel 14536 May 9 19:10 /usr/bin/su*


-r-xr-xr-x 1 root wheel 14536 May 9 19:10 /usr/bin/su*

Note the 'r-s' in the first one, this is the way it should be. If it looks like the second, you lost the setuid bit on su, and should be able to fix it with sudo:

sudo chmod 4555 /usr/bin/su
If it looks like the first, then I'm not too sure what the problem may be. One thing is run

which su

and make sure it says /usr/bin/su and not some other su on the system. If the result is /usr/bin/su, then check things like /var/log/system.log and see if anything is logging there.
i've got the same problem.

i've checked its using usr/bin/su with "which su" but the privileges say:

-rwxrwxrwx 1 root wheel 14704 Jan 17 14:58 su

it won't let me sudo to change the privileges to the 4555 like you suggested tho... it says:

Sorry, sudo must be setuid root.


chmod: su: Operation not permitted

any ideas?

thanks in advance.