Running app not showing up in the dock


Just launched iCab, and it didnt appear in the dock... I'm on it right now, everything works, but no docked icons...
If I minimise a window and hide iCab, the minimised window stays in the dock instead of hidding under iCab's icon (normal since there isnt one ;) ).
Never had this problem before, strange. Tried launching other apps, had no problems with them. Tried quitting iCab and relaunching, still no icon. Tried dragging iCab's icon to the dock, it does show, but as if it was not running (ie no triangle underneath).
iCab does show in the 'kill app' window.
Strange... I'll go repport it to Apple. Below is a link to a ss if you dont understand what I mean.



icons not showing up for you, I have falsies showing up in tho dock. I go to launch one of my favorite apps, to find that it says it's already running... so I click it to bring it to the foreground... and some other comes foreward. As if the dock yelled at the queue something like "number 4 please step forward."

I'll just log out and back in again and see what that does.