Running sendmail, procmail, pop3d, and pine


So I got it booted, with ftp and apache running I thought I was on my way. Then, I tried to find the rest of the daemons I've become accustomed to on LinuxPPC2K (as well as a few applications).

First off, I had to start sendmail manually, but I don't think it's working. I did my su to root, then put "sendmail -bd" to run it as a daemon. I then ran (blech) mail to see what was coming in. I realized I don't have procmail running so it likely isn't delivering the messages to me because of that.

Next, I need to get pop3d running so I can check mail from work or elsewhere without having to do a ssh session to run (blech) mail.

Lastly, I really want to have pine running. I know, is cool (I was referring to the command line mail application before, not the GUI Mail appication which ships with OS X), but when I'm connecting remotely, I need to run pine. Also, pine has some really powerful features which I really like when sorting through my mail.

Any help is greatly appreciated.
Pine works from the Terminal app (Applications -> Utilities). Start Terminal, then telnet to your remote server and run Pine.

Steve, that's not what he meant.. hehe.. in his case, his MacOS X box *is* "the remote server" so he'll need to have Pine installed on it. That's what he's talking about. :) Many people sit down at their *nix box at home and use pine for local mail anyway... or lazy sods like myself use Pine to get email from a machine 3' away. :D
Hi, I want to know if OSX comes with a Mail server? or could anyone recomend an email server with Virtual domain capabilities..



Hey, Dr.Stein,

use <a href="">The MacOSX port of pine</a> and you get what you wanted ;-)

In the default installation sendmail will complain about group-writable directories and exit. Look at your log-files and change permissions accordingly...

I've been trying to get sendmail to start as a daemon automatically on reboot for two days and I haven't got it yet. I just want to run sendmail as an outgoing mail server because they have forwarding disabled on the Exchange sever at work. I can start the daemon manually on reboot using sendmail -bd on a command prompt. I had no trouble with this on the osx pb.

All I did to get sendmail working was open /etc/hostconfig and change MAILSERVER=-NO- to MAILSERVER=-YES- but I still have to start the daemon manually on reboot.

Does anyone know how to do this?
are u sure u have a config file, if yes, is it the right directory, if yes, is the config file "bug" free. about pine, i can't help u with pine with remote mailservers.
All this takes is a couple simple changes to some textfiles on the drive. You'll need root access to do this, though, and I'd suggest using vi or some other unix command-line level editor to be sure that the file gets saved with unix-style linebreaks.

First, edit /etc/hostconfig, changing the line MAILSERVER=-NO- to MAILSERVER=-YES-.

(Optional step - only necessary if you have a qualified domain name and intend to recieve mail on the machine. Not necessary for sending only.) In the same file (/etc/hostconfig), change HOSTNAME=-AUTOMATIC- to HOSTNAME="".

Now, to get sendmail to startup automatically at boot, you need to edit the file /system/library/startupitems/sendmail/sendmail. Towards the end of the file, you'll see a line that ends with an ampersand (&). Remove the ampersand, and save the file.


To test sendmail, create a textfile (in this example, the filename is testmail.txt). Then type this at in the terminal:

mail -s "Subject of the mail" < testmail.txt

For a slightly clearer example, my test looked like this:

mail -s "Test" < /Users/adam/Documents/test.txt

Wait a few moments, and your mail should show up at whatever address you sent it to!

You may get this error returned to you when you try the test send:

/etc/mail/ line 81: fileclass: cannot open /etc/mail/local-host-names: Group writeable directory

This seems to mean that the root ( / ) directory's permissions are wrong, even though it's giving a different directory. Make sure that the root of the filesystem is set to 755, not 775. To do that type:

sudo chmod 755 /

That should do it!

PowerMac G4 400MHz AGP, 54GB hard drive space, 512MB RAM, Mac OS X 10.0.4, ASD 17" Monitor, Altec Lansing APT5 Stereo System.
The above solution totally helped in getting sendmail to actually startup and run. The problem I have now is that I can only send and receive mail using the commandline mail tools. I can not get mail via the that comes with OS X. I would like to be able to set it up using IMAP or POP3, preferably IMAP. I did try setting it up multiple ways as either, IMAP, POP3, and Unix, but none of these mail types seemed to work. So I don't know if I need to setup some other stuff to enable IMAP and POP3 or if I am just not setting things up correctly in the Then there is there something said above running sendmail as a daemon, perhaps that is my problem. So what should I be doing to get things to work in and other mail clients. Thanks in advance...

to use sendmail as an outgoing mail server just give "localhost" as your outgoing mail server. That way will use sendmail to send mail thus. I don't know how to get it to act as an incoming mail server. This just allows me to send mail from behind a firewall.

If you go to there is lots of good documentation on using sendmail.

If you want both incoming and outgoing mail most sysadmins I know prefer Qmail.